Messed up Dual Boot on Asus - BCDEDIT will not work

#1
I have ASUS that came with UEFI win8 x64
disabled EUFI and installed dual boot win7 x64 (launch csm)

all worked fine BUT one day

I punched a bunch of F keys at start up to get to start from usb and somehow that messed up the bios/boot (didnt think that could even happen)

couldnt boot into either w8 or w7

then tried bcdedit fixs.. with no result

finally the only thing that got me to boot was

bcdboot C:\Windows /l en-gb /s B: /f ALL

which got me booting straight to w7, and i left it at that but now wanting to edit some start up settings i cant get bcdedit to work

C:\Users\Administrator>bcdedit
The boot configuration data store could not be opened.
The volume for a file has been externally altered so that the opened file is no
longer valid.

I've been reading stuff to recreate bcd but they all refer to "c:\boot\bcd" which i dont have in c but in my system partition A:\

DISKPART> list volume
Code:
Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 0     A   SYSTEM       FAT32  Partition    300 MB  Healthy    System
  Volume 1     D   OS           NTFS   Partition     93 GB  Healthy    Pagefile
  Volume 2     C                NTFS   Partition    351 GB  Healthy    Boot
  Volume 3     F   Restore      NTFS   Partition     20 GB  Healthy
  Volume 4         Recovery     NTFS   Partition    900 MB  Healthy    Hidden
im new to BCD and confused

there are 3 BCD files on system partition,

A:\Boot\BCD
A:\EFI\ASUS\BCD
A:\EFI\Microsoft\Boot\BCD
and one in
C:\EFI\Microsoft\Boot\BCD

where will i need to put my new one ? so i can have a proper dual boot back and get bcdedit to work..
do i need it in c:\boot\bcd as well?



I've tried EasyBCD's Under management options to
Reset BCD configuration
Re_Create/repair

just tried "Change boot drive" and it seems to have froze the app
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Reset BCD should be what you need. What happens when you try that?
 
#3
Reset BCD should be what you need. What happens when you try that?

I have done the EasyBCD "reset bcd" it says its successful but nothing changes at start up ... may it be because

could it be because asus bios keeps reads its own bcd in A:\EFI\ASUS or something? After all I ended up in this predicament when i was hitting all F# Function keys while booting up in bios in hopes i get a "boot from" menu and as a result lost HD's dual boot option.
 
#4
i've done another reset in EasyBCD ... then after went to "File>Load System BCD" I get this...
Code:
There are a total of 4 entries listed in the bootloader.


Default: 7
Timeout: 10 seconds
EasyBCD Boot Device: A:\


Entry #1
Name: Windows Boot Manager
BCD ID: {9090be8e-4d7c-11e3-b2e3-08606e0fb7bc}
Device: \Device\HarddiskVolume1
Bootloader Path: \EFI\Microsoft\Boot\bootmgfw.efi


Entry #2
Name: CD/DVD Drive 
BCD ID: {9090be8f-4d7c-11e3-b2e3-08606e0fb7bc}
Device: Unknown
Bootloader Path: 


Entry #3
Name: 7
BCD ID: {default}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe


Entry #4
Name: 8
BCD ID: {aea50cdf-4ba3-11e3-b02d-08606e0fb7bc}
Drive: D:\
Bootloader Path: \Windows\system32\winload.exe
-------------------------------------------------------------------
Interestingly the bcdedit command now works without error

Code:
Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.


C:\Users\Administrator>bcdedit


Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  boot
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {default}
resumeobject            {1f8184a2-14de-11df-9734-f08c6d8c50b0}
displayorder            {default}
                        {aea50cdf-4ba3-11e3-b02d-08606e0fb7bc}
toolsdisplayorder       {memdiag}
timeout                 10
displaybootmenu         Yes


Windows Boot Loader
-------------------
identifier              {default}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             7
locale                  en-US
osdevice                partition=C:
systemroot              \Windows


Windows Boot Loader
-------------------
identifier              {aea50cdf-4ba3-11e3-b02d-08606e0fb7bc}
device                  partition=D:
path                    \Windows\system32\winload.exe
description             8
locale                  en-US
osdevice                partition=D:
systemroot              \Windows
and YET I'm still loading directly into Windows 7 without a menu poping up for 10 seconds .... as if "bcdboot c:\Windows /l en-gb /s b: /f ALL" still preceding.
I read that /f ALL parameter updates the BIOS settings including UEFI firmware/NVRAM. Not knowing what that means entirely, could that be writting somewhere higher in higharchy? Guru please share some insight.