Multi-boot Vista/Xp/Ubuntu

#1
hi everyone.

So my situation, i've got vista installed on a hard drive works fine, then i've got xp and ubuntu both installed on a second hard drive. easyBCD is installed on Vista and i've configue it for ubuntu and it works fine.I can boot into vista and ubuntu without any problems in the boot menu. Then I've added windows xp in easyBCd on vista set the drive on c: ( I've tried on d: and K: ( drive letter of the second hard drive on vista )) but when i restart and select windows xp from the boot menu it hangs on a black screen forever. What did I wrong ? ( I can run xp in the grub menu when I boot on the second hard drive). Thank you very much.
 

JustinW

Super Moderator
Staff member
#2
Welcome to NST dragon_hearth :smile:

Use these troubleshooting steps to help you or check out NeoSmart's wiki how-to articles.

1) Have you tried to boot from the second drive and boot XP normally that way?
2) Was XP installed after Vista or before?
3) Did you verify that ntldr, ntdetect.com, and boot.ini were at the root of the partition for which you referenced when you added the XP entry?
4) Did you check boot.ini to make sure the default/OS entry for XP is pointing to the correct disk and partition?
 
#3
1) yes i've tried to boot from the second hard drive with and it works properly ( even without grub it works )
2)vista was installed firts and vista and xp are on different hard drives
3)i've set the entry were xp is ( the drive letter that is shown on xp (c:smile: ) and I've even tried with the drive letter of xp within vista both didn't work
4)no have'nt checked that because xp works fine .... ^^

thanks for the quick reply and the welcome message ^^
 

JustinW

Super Moderator
Staff member
#4
Vista is your active boot partition. Assure that XP's boot files are copied there if not present and make the XP entry you add in EasyBCD point to Vista's partition rather then XPs.
 

JustinW

Super Moderator
Staff member
#6
Have you gone to folder options --> view tab and selected "View Hidden Files and Folders" and unchecked "Hide protected operating system files"? Without doing this, you well be unable to view the files (at the root of the partition) in Windows Explorer.

Are they missing from the root of Vista's partition? If they are not there, check the root of XP's parition. If they are located on XP's partition, try copying them (don't move) to Vista's partition and follow the previous steps.
 
#7
ok so i've copied boot.ini, ntdlr, ntdetect.com to root of vista; deleted the entry of windows xp, recreated one reboot and select win xp and still the same black screen with no errors. The boot.ini shows this :

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect


and when i open disk manager win xp is on the drive(o) and the first partition .
 

JustinW

Super Moderator
Staff member
#8
Change rdisk(0) to rdisk(1) for boot.ini for both the default and OS entries ONLY on the Vista parition. Leave the boot.ini on XP's parition untouched.
 
#9
My Vista/XP/Ubuntu Story

I have Vista 64, Vista 32, and XP set up already with Easy BCD on a new machine. Works pretty well and have to commend EasyBCD as being a wonderful product.

The problem is Ubuntu.

My set-up: Asus Maximus Formula with Intel E6850 3.0 ghz chip with 4GB OCZ memory. Two 320GB Seagate drives configured in a RAID 0 Stripe using the on-board SATA Raid of the Intel ICH9R controller on the motherboard.

Likely culprit of the problem in my estimation: My RAID setup combined with Ubuntu's lack of ease of setup (compared to Windows) of a RAID configuration. (Windows just lets you load RAID drivers on boot-up / install).

I've been trying to install Ubuntu on a third hard drive outside the RAID Stripe. Just can't get the dang thing to boot. Tried NeoGrub with a menu.lst file ripped from the install boot/grub directory. Tried a boat load of hard drive locations in case Ubuntu or Vista Boot Manager was just getting confused as to where the Ubuntu directory is. Also tried the Linux menu entry in BCD.

Also tried Grub install to MBR and that was a nightmare. I'm lucky I got my Vista 64, Vista 32, and XP boot capability back. Had to run a bunch of recovery stuff and my XP partition got hidden somewhow in the process and had to run PTEDIT.EXE and a whole bunch of crap just to get my previous Windows boot menu back. I'm an old OS/2 fan and I've had a lot of experience with OS/2 Boot Manager and multi-boot setups.

But I must confess that this Ubuntu set-up has to be the most confounding multi-boot configuration I've ever tried. I'm very new with Linux and Ubuntu and the terminal is just real foreign to me still so I fear that is my weakness.

For the life of me, I can't get Ubuntu to boot. I also get errors seeing the /dev/sda device when I use the "fdisk -l" command in "terminal" mode.

I can boot the Live Ubuntu CD just fine but I can't seem to get an actual install to boot for me. I've been going with the following install guides and still end up empty handed:

http://neosmart.net/wiki/display/EBCD/Ubuntu
http://apcmag.com/how_to_dualboot_vista_with_linux_vista_installed_first.htm

Am I just hopelessly stuck without being able to install Ubuntu to a hard drive and set up a boot?

I've installed Ubuntu to the third hard drive but I can only get back in to see my Ubuntu installation by booting the Ubuntu Live CD.

I've got Ubuntu installed on an old crusty laptop with two hard drives and got the multi-boot with Grub on that thing whipped up with no problems. I have been impressed with Ubuntu as an OS so far and wanted to roll it out on a more powerful platform.

I've read the varoius RAID documents on the Ubuntu community forums. Still not a lot of help there though.

~cejack
 

JustinW

Super Moderator
Staff member
#11
dragon_hearth: Glad you got it working!

cejack: There are prob. two reasons for why it isn't working:

a) Ubuntu is crashing as it tries to access members of the RAID set
b) Your boot parameters for (hdx,y) are wrong

Things to try...

1) Boot from Ubuntu's drive directly to see if it working.
2) If it won't trying step 1, change x in (hdx,y) to 0 as you are booting. Grub supports one time editing of boot parameters during boot time.
3) Follow step 1 and 2, but disconnect all of the drives in the RAID set to see if it was reason A that is the cause of the problem.

If it is RAID that is causing the problem, I have no other advice to give other then finding a driver that'll support in under Ubuntu or disconnecting drives in the RAID set everytime you wan't to boot Ubuntu. You could also optionally choose to re-install OSes normally without a RAID configuration.

If it s a boot problem, notice that following steps 1 and 2 allowed you to boot correctly. Changing the parameters for x in (hdx,y) in /boot/grub/menu.lst to the number in which Vista recognizes the disk in Disk Management and adding a Linux entry in EasyBCD pointing to the Ubuntu partition w/o first having installed NeoGrub well allow you to chainload Ubuntu's grub from it's bootsector from bootmgr and successfully boot Ubuntu.

If you do this however, keep in mind that you well not be able to boot Ubuntu if you were to boot from its drive straightaway. Why is this you might be asking? Since grub from Ubuntu's drive is first loaded, the disk is considered disk 0 (Regardless of how Vista or the BIOS sees it) and x in (hdx,y) must also be 0 in order to boot Ubuntu successfully. You would need to use Grub's edit feature as you are booting and change it to boot Ubuntu in that case.

There is, however, a solution to this problem that'll allow you to boot Ubuntu correctly either way without having to edit parameters on one or the other as you are booting. I have avoided this problem by using 2 distros of Linux on the same drive. If you are interested, say so and I'll go into further detail about how to set it up.