Multi boot windows 7, windows 10 and ubuntu 18.04

Hi all.

My question is "proactive" but I suppose it may help also many other people in the future.

I already use EasyBCD successfully (excellent software insofar!) to dual boot between windows 7 and windows 10 with no problems. I would like to add a third OS to my system (ubuntu 18.04) but I read on the internet about some people facing serious boot problem after installation (they could not boot either windows or ubuntu). I checked my windows 10 and windows 7 systems and both boot in BIOS legacy mode. I believe this is "good" as usually boot problems arise with windows in EFI mode. My questions are: has anyone already installed ubuntu 18.04 alongside windows 10 and windows 7 (both in legacy mode) successfully (i.e. 3 OS)? What is the best method to secure myself in case something could go wrong and not be able to boot at all? Obviously I don't want to mesh up my system with restore disks ets... I do have read the procedures how to prepare the ubuntu ISO boot USB disk, disable windows 10 from fast booting etc. and also what to do after installation to "deactivate linux grub booter" and replace it with windows MBR but this time giving me the third choice of ubuntu 18.04 as well. Thank you.
I am in exactly the same situation having installed Ubuntu 18.04 with grub2 on the Linux partition (ext4) as an add-on to a working system with Win 10 + Win 7. EasyBCD 2.3 is installed on the Win 10 partition (dedicated drive).
Whichever way I add Ubuntu - directly with Grub2 or NeoGrub - the result is the same - any access to Linux partition produces:
Error 14: FIle system compatibility error, cannot read whole file

NeoSmart published a method which apparently allows access to Ubuntu 18.04 stating the following:
"Due to a bug in Ubuntu 10.04+, the current steps are rather more convoluted than they used to be in previous versions, requiring the user to first give control of the MBR to GRUB2, and then use EasyBCD to put the Windows bootloader back in control. We have brought this issue to the attention of the Ubuntu developers, and hope to have it resolved soon."

Assuming that my previous system used Ubuntu 16.04 accessible from EasyBCD 2.2 installed on Win 7 partition, makes me wonder what happened that Ubuntu 18.04 and EasyBCD 2.3 stopped liking each other.
Is the above message still valid? If so what is this enigmatic "bug in Ubuntu" no longer allowing GRUB4DOS 0.4.5c to access ext4 partition?
Is there a way around it without a convoluted way of installing Ubuntu loader?

Evidently something changed / got broken between Ubuntu 16.04 + EasyBCD 2.2 and Ubuntu 18.04 + EasyBCD 2.3.

I think, many people would appreciate a comment from the developer.
I have a similar problem. I had a dual boot Win 7Pro and Ubuntu 16.04. on an MBR disc.
(I know EFI has issues but this is MBR and legacy - should be simple over the years I have had many multi boot systems - I even once had a quad boot system working once XP, Vista, Win 7 and Linux)
I was using the Windows boot manager to select which OS to boot.
Win 7 was on a Primary partition.
In an extended partition I had 3 logical partitions, one for Linux, a Linux swap and a Home partition.
This was all working perfectly.
I (foolishly?) decided to upgrade to Ubuntu 18.04.
The install routine found the older Ubuntu OK.
I selected to replace 16.04 with 18.04 in exactly the same configuration as before - should have been simple.

After installation nothing would boot.
A repair using the Win 7 Pro install disc got Win 7 back with the boot menu.
On the boot menu there are two options
Windows 7

Windows 7 now boots fine and is working.
Selecting Linux just gives "Grub" prompt.

I have upgraded to EasyBCD 2.3.
I have tried Grub, Grub2 and NeoGrub nothing works.

Before I totally wipe the extended partition and do a clean install has anybody any ideas?


Just to see whether the problem is specific to Ubuntu, I have installed a couple of other non-Debian Linux systems - Manjaro and openSUSE, both on ext4 (journalling) file system. The effect is the same - menu entries created for GRUB2 get stuck at GRUB4DOS prompt, from where the ext4 file system is not accessible. I may add that all my Linux systems boot perfectly fine from GRUB2 installed on the MBR of one of the drives (accessible via BIOS boot options), each one using its own GRUB2 installed on the Linux partition.
It looks rather obvious that there is something incompatible between the EasyBCD 2.3 and ext4fs.
The problem appears to be that EasyBCD and/or Grub4DOS can't handle more than one Linux system on a single disc, probably because a data field is too small.

In my case:
HDD0 contains the following partitions: C=Windows7 (NTFS); D, E, F and G=Data partitions (FAT)
HDD1 contains the following partitions: sdb1=Linux root (ext4), sdb2=Extended Partition, sdb5=Linux Swap, sdb6=Linux home (ext4)

I have successfully used EASYBCD to boot using a Windows MBR. The Boot Menu has Windows and Linux. If Linux is selected, it brings up the Linux boot menu. I have NOT set the timout to 0, so that I can use the other Linux menu items (i.e. diagnostics mode, memtest, or returning to Windows7).

I have successfully used the following procedure with several versions of Ubuntu and Linux: [Install Windows7]; Install Linux, using the Linux boot menu; boot Windows7. Using EasyBCD3: [Add new Entry for Linux]. BCD Backup/Repair > Recreate/repair boot files (which writes a Windows MBR and makes the Windows boot menu primary). Edit Boot Menu to set the default .

Recently I added Linux Mint 19 to HDD1. So sdb1=Mint 18.3 root (ext4), sdb2=Extended Partition, sdb5=shared Linux Swap, sdb6=Mint 18.3 home (ext4); sdb7=Mint 19 root (ext4), sdb8=Mint 19 home (ext4)

When I use the above procedure, windows boots fine, but selecting "Linux" from the Windows boot menu results in
"GRUB > Error 14: Filesystem compatibility error, cannot read whole file". This error is generated because some of the filesystem reading code in GRUB4DOS has limits on the length of the files it can read. This error is returned when the user runs into such a limit. Also some old BIOS or BIOS settings if not AHCI may cause grub boot issues if boot files or grub files are beyond a very old BIOS limit of 137GB.

If Mint 19 is installed as sdb1 and sdb6 (with no sdb7 or sdb8) it works fine. Similarly, if Mint 19 is installed on another disc (as sdc1 and sdc6) it also works. It's only when there are two Linux systems on the same volume that the problem occurs.

It seems that it would be fairly simply for EasyBCD to allow a larger file length and/or use a later version of Grub4DOS which should fix this problem. Until it does, we have to use the Linux boot menu. :frowning:
Last edited:
I have Mint 19 setup that can't get working, all on separate drives
Win 10
Win 7
Mint 19

EasyBCD works with both windows drives as expected, but Mint 19 can't get working (Mint 18.3 worked fine before)
I have been able to use PC Bios "F8" select drive menu to boot widows but Mint 19 fails to boot when other drives are powered up.
Mint 19 only boots as a single drive after initial install and fails never boots again after the Windows 10 & 7 drives are connected
Have run out of things to try here