multiboot only display one f8 options.


i have 4 OS in 4 partitions but only first partition shows the press f8 options and i have no choice to debug my other OS in case of need.
c - win7
d- xp
e- ubuntu
f- fedora
so only in win7 option i can use f8 options but system do not show press f8 option for my remaining three OS.
do you know how to resolve this?
None of the rest have F8 options. For Windows XP, you have to hit Enter and immediately afterwards F8.
yes you are right! thanks!
but is there any setting to show or hide f8 options in bcd or manually in the all windows based os in boot menu!
Bootmgr (Vista/7) will enter its own extended boot menu on F8
Bootmgr doesn't load XP, it chains NTLDR (the XP boot manager/loader)
NTLDR still loads XP even in a dual-boot
NTLDR has its own extended boot menu on F8
You will need to select XP from the W7 menu, hit enter, then immediately start tapping F8.
That intercepts the chain to NTLDR in time to make it display its extended boot menu instead of the normal one.
how to change or edit boot order in windows and linux manually?
To change boot order of Windows boot menu, open EasyBCD in either XP or W7, go to the entries page, and you should see options to move selected entries up or down so you can rearrange them in whatever order you want. Then just click the save button.
As for Linux, you would need to edit the order of entries in either a menu.lst or grub.cfg, depending on whether you're using Grub 1 or Grub2. Just open the file in a plain text editor (such as gedit), select the entry you want to move, cut it (Ctrl + X), put the mouse cursor above or below whatever entry you want to put it above or under, then press Ctrl + V to paste, then just save the file. Your boot menu should now reflect whatever changes you put in.
Last edited: