NeoGrub boot ISO seems broken with Legacy+UEFI

Discussion in 'EasyBCD Support' started by audioscavenger, Dec 4, 2017.

  1. audioscavenger

    audioscavenger New Member

    Joined:
    Dec 4, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    hello! Thank you for such a wonderful product, I love it.
    I can easily modify my boot menu and add iso entries with neogrub :smile:

    It works like a charm on my laptop with Windows seven, which has a legacy bios.
    I have an issue with my desktop though.
    • config: MSI z77 Mpower motherboard, SATA SSD disk with MBR (not GPT), 4 partitions including Windows seven.
    I activated Legacy+UEFI, and I can access the neogrub boot menu, where I listed some iso files to boot, here is a sample of the iso declarations, they are all the same:
    menu.lst:
    Code:
    title CorePure64-8.2.1.iso
    ls /VM/ISO/CorePure64-8.2.1.iso || find --set-root /VM/ISO/CorePure64-8.2.1.iso
    map --heads=0 --sectors-per-track=0 /VM/ISO/CorePure64-8.2.1.iso (0xff) || map --heads=0 --sectors-per-track=0 --mem /images/CorePure64-8.2.1.iso (0xff)
    map --hook
    chainloader (0xff)
    
    On boot when i chose an iso entry, the iso file boots fine, but then when the linux kernel tries to load its intramfs/initrd etc it fails. Same issue with all the iso I have: tinyCore, DSL, lupu, Nas4free, etc
    It's like it cannot see its own root fs whereas it should be mounted by neogrub since it boots up fine ?

    I am really confused and I don't see where the problem comes from.
    The only differences with my laptop are the bios uefi, and the hard drive which is an ssd.

    - I tried booting the iso files on the second hard drive, 2TB SATA seagate, MBR, but every other reboot, neogrub says the disk (hd1,0) doesn't exist.
    - I tried different flavor of the iso declaration, with hd32, root (0xff/hd32) after map --hook, rootnoverify, etc, no luck.
    - For DSL, I tried adding specific kernel paths like that:
    kernel /boot/isolinux/linux24
    initrd /KNOPPIX/KNOPPIX
    It then load the img but fails because my parameters have to be specific for that distro, and anyway I don't want to craft specific neogrub entries per distro because it would defeat the purpose of emulating a cdrom.


    So, I suspect it's linked to the UEFI bios because the behavior of neogrub is not stable, when it comes to detect the available disks.

    I haven't found a post anywhere with this kind of issue yet.
    thanks for any help!
     
  2. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    14,360
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    Chicago
    It can't be a UEFI issue as NeoGrub won't even load up in UEFI mode.

    It's possible that the issue is an NVMe drive?
     

Share This Page