Network Settings Cannot be Modified on Xbox 360

JustinW

Super Moderator
Staff member
#1
I'm not a gamer myself, but I am the technical come-to guy. So naturally I'm the one who has to "make it work". Anyway, my brother has an Xbox 360 he is trying to connect to our wireless network using the Xbox wireless adapter. The adapter doesn't seem to be the problem, but rather, there is something up with the settings menu.

The sections to either setup (automatic or manual) configuration for IP addressing and DNS are fine and allow you to edit them. The section where you actually enter a network SSID, network security key, etc. is faded out! Imagine that... a settings menu you cannot use to change settings... great!

It is not the network's configuration that is causing this (We can't even tell the Xbox which network to use let alone scan for one!)
 

mqudsi

Mostly Harmless
Staff member
#2
I don't have an XBox myself (nor access to one), so I'm more than useless here..
But - in the Windows world at least - when something is faded out it means that there's a problem.

Either wireless is disabled in the XBox settings, it can't detect the wireless module, wireless doesn't work when wired is connected, etc.
 

JustinW

Super Moderator
Staff member
#3
Well, if it helps anyone...

The adapter has an indication light on it that lights up when connected to the back of the Xbox. The light is solid red. A quick lookup of the light codes show that this means the network adapter is ready to connect to a network.

Here's some troubleshooting things I tried:

1) removed/re-installed adapter
2) reset XBOX
3) reverted to factory default settings
4) Entered IP and DNS information manually (Thought that manual configuration of those menus would give you access to the network connection menu... no go :frowning:)

It's kinda hard to troubleshoot menus that are faded out that you cannot get access to. The manuals found via hardcopy or xbox.com are for complete newbies to networking. A search for the issue has yet to reveal any results. Since this is the "recommended adapter" for an Xbox with offical backing by Microsoft, I am surprised no one else has had the same issue or that Microsoft hasn't confirmed or explained what could be the problem. Thier Xbox support hotline just reviews the steps outlined in the manual and when issues don't get resolved, they just give you a case number and inform you to call back if you are still expereincing the problem.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
Is there anything different about the menus when the adapter is removed?

(I mean, do you know that the XBox itself can see the adapter for sure?)
 

JustinW

Super Moderator
Staff member
#5
!) Nope. I've tried resetting the XBox and plugging the device back in

2) The adapter should be PnP, and it is self-powered off the USB bus by the XBox.

Nice try, but I guess its a lemon.
 

mqudsi

Mostly Harmless
Staff member
#6
But that doesn't necessarily mean it's being recognized.
For instance, sometimes I plug my USB mouse in, it lights up, but the computer doesn't see it and it doesn't appear in the device manager.
 

JustinW

Super Moderator
Staff member
#7
It would be genious for Microsoft to have a way of checking for whether or not the XBox can detect the adapter. Unfortunanly, ther isn't.

In the Windows world, you could change network settings no matter the state of the adapter (even if one has yet to be installed)

The XBox has no "General Settings" menu in which an option to enable/disable Wireless connectivity exists. He just got it today so hopefully we can swap it out if I can't get it working :smile:
 
#8
Im not sure if this helps or not , but i was trying to connect to the internet the other day but i couldnt connect because of the type of encryption i had on my network. I took it off and it worked.
 

JustinW

Super Moderator
Staff member
#9
After some thinking about it some more, I believe the menu is supposed to be like that by default. I think that it'll be activated if the XBox recognized the adapter. Regardless, I do not no of another way of accomplishing this.

My network is not the issue, though I'll be more then happy to briefly mention what the XBox supports. According to XBox's manual, the system has support for 802.11a/b/g and WPA. My network is setup to support a mixed enviornment between 802.11a/g and WPA/WPA2 clients. I normally have MAC filtering enabled, but I disabled it, so there should be no other issues as far as the network is related.
 

mqudsi

Mostly Harmless
Staff member
#10
Yeah, that's my assumption as well. Looks like you have a faulty adapter.
 

JustinW

Super Moderator
Staff member
#11
My brother's an idiot and threw away the packaging though... lol

I'll leave it to him as to wether or not he wants to get another one and get it set up. I've tried internet conectivity on a DS and a PSP with no success as well. Gaming systems definetly seem to have not been intended for internet play in the first place :smile:
 

JustinW

Super Moderator
Staff member
#12
Well, a new adapter from Pelican did the trick!

It isn't powered straight from the Xbox and it uses the Ethernet port rather then USB. You just connect it to a PC, run the installation to configure settings, and then unplug and plug into the Xbox. This adapter was also about 45$USD cheaper, but it works very nicely! :smile:
 

mqudsi

Mostly Harmless
Staff member
#13
That's great, Justin. Did you find out if the old one was physically damaged?
 

JustinW

Super Moderator
Staff member
#14
The old one as far as I could tell was not physically damaged, but you never can tell if these companies test every unit before shipping them out. Sometimes a generic or a less popular choice is the best. My brother did not need the packaging to return the product, so he just simply swapped it out for the other at a cheaper price.

This paticular adapter is nice because it connects to the Xbox's ethernet port. The Xbox sees it like it is plugged into a wired network, but this device takes the settings you specify that are stored in its memory and connects to the wireless network and does the conversion from wired to wireless for you.
 

JustinW

Super Moderator
Staff member
#16
Networks mixed; wpa/wpa2 for compatiability. The pelican as far as I know that we did get working only supports wep/wpa. The old adapter was returned. The Xbox didn't appear to have even detected it let alone connect to any APs.