New version, DOS issue

#1
version 2.0.2.117

Hello everyone. First, I've searched for both DOS and 6.22 with no results so I apologize if this has been adressed before.

I previously had vista/osx/6.22/OS2 booting via easyBCD.
I vaped my earlier installs and went with win7/6.22/a newer osx and can not get dos to boot. Before, osx saw the dos partition and there was an option to boot it after selecting to boot osx, this new version however fails to see it.

SO I ADDED IT TO easyBCD
Invalid system disk it tells me. During initial setup, easyBCD spat out instructions to copy io.sys and msdos.sys to the "start of the active partition". Obviously these files were on dos partition, so I copied them over to the win7 partition, rebooted, INVALID SYSTEM DISK.

I set the dos partition to active, reboot, and it comes up fine. Drop win7 dvd in, switch the win7 partition to active and boot back into windows, and look over some more settings, not knowing what's causing this error I copied all the bootup files to the win7 partition (like all the files req'd files you'd see on a dos boot floppy) and I'm still getting the same error. What else needs done? I know I could install a small linux distro and just use grub, but it would really be a waste of space.

Okay, google searched with site:neosmart.net and came up with a few DOS posts, but all were really old and not really relevant.

Any ideas? Guru?

THANK YOU

Real-mode Boot Sector
---------------------
identifier {93468cc0-b871-11df-8170-d5654e058d43}
device partition=C:
path \NST\nst_dos.mbr
description MS DOS 6.22 / WINDOWS 3.11

Addendum:

After some messing around, now I'm getting:
"Remove disk and other media"
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
You need to

1) Set the Windows 7 partition to boot, and enter Windows
2) Use EasyBCD | BCD Install/Repair | Change Boot Drive and select the DOS partition
3) Add the DOS entry again

Let me know if that works.
 

mqudsi

Mostly Harmless
Staff member
#4
You're most welcome, skifdank :smile:

You're awesome and we love you too!