no neosmart answer no support


I bought me months ago (September) the easy recovery prof edition to repair my new pc, amd 7950X3D, Asrock Steel Legend X670E, Crucial TN700, Samsung 990 pro + WDBlack770 (all 2TB). When I boot I get errors, goes to repair and any of the repair possibilities offered, any one doesn't work. Hardware is fully tested by pc shop, all ok. Since I took it back home from the shop it was running with on one of the 3 (win triple boot) fine until an os update. Since then it keeps booting, no way to get into safe mode nor fix it with all the recommended programs nor boot from any other drive or media. I installed windows a dozen times, all the same.
Bought me easy recovery prof, to bring this pc to run. Iso downloaded, burned a few times, get failures while booting up, tried with usb, all the same result, startup breaks in the attached shown processes, no way to bring it up for running.
Wrote to neosmart support, 1st response came while on vacation, download link from a different iso no longer available. Wrote 3 times to support, no answer.
Do I get it to run or do I have to worst case get refund with PayPal.
Please let me know, appreciate your help, thanks.

does anyone know a reason why neosmart simply ignores my emails and requests for support and deletes my post?
i can not run the easy recovery win11 version, the boot simply aborts
help needed


  • 20231001_182114.jpg
    1.8 MB · Views: 7
  • 20231001_181726.jpg
    2.1 MB · Views: 7
  • eneosmartsupport.jpg
    28.8 KB · Views: 6
Last edited by a moderator:


Staff member
I sent him a text on his personal phone. He acknowledged it. Have you checked your Spam/junk mail boxes?
If you emailed any logs or attachments he will take a while to analyze them.


I sent him a text on his personal phone. He acknowledged it. Have you checked your Spam/junk mail boxes?
If you emailed any logs or attachments he will take a while to analyze them.
Thank you Peter, yes, I always take a look at the spam and junk folders.



I received the iso link (see print screen below) yesterday, burned it to a cd-rom and get the identical failures as the first post. Tried to start it with a bootable usb stick as described on the support, same result. Get stuck in the same prompt. There is no way to start EasyRE. Can you please help on this, I couldn't start it out of the shown prompt. Do I need an specific command or what can I do on this.


  • EasyRe reply.jpg
    EasyRe reply.jpg
    22 KB · Views: 3
  • 20231108_102558.jpg
    619.3 KB · Views: 3


Mostly Harmless
Staff member
The picture you posted shows that the CD is giving read errors - there were either issues burning it, the CD is scratched, the drive is dying, or the cables for the CD drive are damaged or not seated correctly are the most likely reasons.

I would create a bootable USB instead; instructions at Creating a bootable USB with Easy USB Creator
You can use Easy USB Creator as indicated in those instructions or try Rufus if those don't work for you for some reason.


So now I found out that Easy Recovery works when in bios secure boot is disabled. I could start several times the recovery program and end it and restart, but then the uefi was not accessible, failure, repair and so on. Now I sudden found out that the ASRock Steel Legend AMD X670E does have problems with more than 1 32Gb ram modules and crashes, modules are on the memory QVL list, so I took them all out put 1 in slot B2 and now pc runs having sometimes a blue screen stating driver problems. There is no way to run the 128 Gb nor 64Gb ram.
Explain users to disable secure boot as it doesn't either work. Thank you for the support.