NTFS5: No ang0 error / solved for me

#1
Hi, I was going to write a post asking for help on the "no ang0 error", but figured it out while I was writing it. Perhaps others have the same problem.

I have 3 OS's installed. Win7 (with bitlocker), Win8 and Ubuntu. I'm using the Win8 bootloader and can boot Win7 and Win8 just fine. When I try to boot Ubuntu I get:

Try (hd0,0): NTFS5: No ang0
Try (hd0,1): NTFS5: _

I have 2 drives:

disk0: [System reserved 100M] [Win7 bitlocker]
disk1: [Shared Win data] [Win 8 no bitlocker] [Win recovery] [Ubuntu / (inc. boot)] [Ubuntu swap] [Ubuntu data]

I run EasyBCD under Win8, and the ang0 file is on that partition. It looks like the boot sequence hangs on the bitlocker encrypted partition.

So. I booted to Win8, went into computer management->disk management and assigned the [system reserved] partition a letter. Then I copied the ang0 and NTS folder from the Win8 C-drive to the [system reserved] partition and that solved the problem.

I can now boot win7/win8/Ubuntu with bitlocker on the windows partitions.

Cheers
 

mqudsi

Mostly Harmless
Staff member
#2
Very interesting!

This could potentially shed a lot of light on an error that, in general, should have been solved a long time ago, yet people still sporadically complain of.

Thank you very much for sharing this, at the very least we have something to tell people to try and we could even possibly detect and prevent this configuration from within EasyBCD if it sees a BitLocker drive.

That said, if you assign the boot partition a letter there is no need to manually copy ANG0 to it; EasyBCD first tries to install boot helper files to the boot partition and only when it's unmounted does it resort to using the Windows installation partition.