Problems with dualoboot Windows 7 + OpenSUSE ---> GRUB4DOS

#1
Problems with dualoboot Windows 7 + OpenSUSE ---> GRUB4DOS

Hi guys
from few days I'm going crazy trying to solve the problems of installation of OpenSUSE 12.3 on dualboot with Windows 7 and EasyBCD as manager of the MBR.
It is not the first time that I do a dualboot configurations but in the past I've always used distros like Ubuntu and I must say that I never had problems getting it all work.
But since I decided to switch to OpenSUSE I'm failing to find the key to the problem.

In short my HD configuration is this:
- Recovery partition NTFS (primary)
- System reserved NTFS partition (primary)
- Windows 7 partition (NTFS and primary)
- Partition for linux distro (ext4 logical)
- Partition for swap (logical)

At the time of Ubuntu I was doing the following simple steps:
- From windows I created 2 partitions (for root and swap - /dev/sda5 and /dev/sda6)
- I installed ubuntu on root partition
- at the restart I used the windows cd recovery to launch these 2 commands:
* Bootrec.exe / fixmbr
* Bootrec.exe / fixboot
- From windows with EasyBCD I added a new entry to the list of OS managed by the bootloader and the game was done!

I did the same thing with OpenSUSE (with liveUSB) but it does not work.
Ok I deleted everything (wipe linux partition and reset EasyBCD configurations) and I tried again by following step by step this guide (Dual-Boot openSUSE 12.3 And Windows » TweakHound )
This time I have specifically installed GRUB2 not in the MBR (as has happened before) but in the same / partition.
And this time I have used, not the usb-live, but the dvd.
Result: does not work the same!
As soon as I click on the new entry of EasyBCD, instead of loading grub2 I get a prompt with GRUB4DOS ...
For the 3' times I re-install everything with this time Linux Mint (to understand if was a problem with OpenSUSE) but at the end I see always the damn GRUB4DOS
Now I do not know what to do anymore..
Can you help me?

Addendum

Reading some topics in this forum, I found 2 interesting tips

Try running the following commands in the GRUB4DOS prompt:

Code:

ls
root (hdX,Y)
ls (hdX,Y)/dev
kernel /vmlinuz root=/dev/sdX,Y
initrd /initrd.img
boot

that I have try but I have some errors..
and this:

I tried this:
>root(hd0,4)
Filesystem type is ext2fs, partition type 0x83
>kernel /boot/vmlinuz-2.6.31-14-generic
[Linux-bzImage, setup=0x3400, size=0x3bef40]
>initrd /boot/initrd.img-2.6.31-14-generic
[Linux-initrd @ 0x7f7b0000, 0x80fd20 bytes]
>boot

(the 2 topic are:
https://neosmart.net/forums/showthread.php?t=5378
https://neosmart.net/forums/showthread.php?t=9471)

So I have launched the commands
* root(hd0,4)
* kernel /boot/vmlinuz
* initrd /boot/initrd.img-xxx-generic
* boot

and finally I was able to start OpenSUSE :smile:

The question is: how can I store these command?? Because if I restart the computer and choose the EasyBCD entry reappears GRUB4DOS again -,-
 
Last edited: