repair or create bootloader for Win7/ Vista Home Premium/ and Linux Mint 15 xfceGreet

#1
Greetings to all,

And I wish to thank Terry and the others for their help in the past.:smile:

Here is my current situation:

There are three Hard drives in this computer set up in serial A-T-A

Disk 0 which is (C:smile: is a 1 Terabyte drive and Windows 7 Ultimate is the installed Operating System and was the OS which the machine booted into upon start up after showing the "Windows Boot Manager"

Disk 1 which was (D:smile: and has (had) Windows Vista Home Premium installed on it as the Operating system and was second in the windows boot manager

Disk 2 which was (E:smile: and previously had Windows XP Pro installed on it as the operating system and was the third choice in the boot manager.


Recently I decided to reformat the (E:smile: drive and install the latest version of Linux Mint 15 xfce Codename: Olivia on it and finally start the learning curve on Linux.

I ran active killdisk to wipe the (E:smile: drive and then attempted to install Linux by booting from the dvd I created and I believe the end result is I installed Linux on the (D:smile: drive
I believe both "Vista and "Linux Mint" are on (D:smile: drive.

I can boot into all three Operating systems but I must do so in a round-a-bout way now since I flubbed the intended location of the new linux installation and messed up the bootloader.


What I am trying to accomplish is:

Disk 0 (C:smile: drive with Win 7 boots first and is 1st choice in Easy BCD loader to be created.

Disk 1 (D:smile: drive is re-configured so that "Vista Home Premium" is the only OS on that disk and is re-extended back to its original size of 320/298GBs

Disk 2 (E:smile: drive is set up to have the linux Mint OS installed to it and is the 3rd choice in the easy BCD loader.

I am providing a screen shot of the "Win 7" disk management page as it is now and I am also providing another screen shot of how the "Easy BCD 2.2 Community Edition" sees my "View Settings"

Thank you very much in advance for any help rendered.

ranger72:smile:
 

Attachments

Terry60

Knows where his towel is.
Staff member
#2
That appears to be a BCD on Vista you've attached, not the live BCD on "Sys.. Res..."
Check EasyBCD > Tools > Options to make sure you've not got "Automatically load....." set to the wrong place.
 
#3
Hi Terry,

Automatically load was not checked. I have re-booted back into win 7 and will attach screen shots of the "Disk Management" window with (C:smile: drive running win 7 and a screen shot of easy bcd from win 7
 

Attachments

Terry60

Knows where his towel is.
Staff member
#4
Can you see a dimmed entry in the auto-load box ?
The reason I ask is because Disk Management shows the boot device (system) is "System Reserved" (which it should be on W7) but the EasyBCD view settings shows boot device = D, which would only be the case for the Vista BCD.

Disk Management flags have the following meanings
"boot" = "this is the system you're running"
"system" = "this is where I found the boot files for the currently running system"
"active" (on the first HDD in the BIOS boot sequence) = "this is where I started the search for the boot files"
"active" (on subsequent HDDs in the BIOS boot sequence) ="this is where I will look if I don't find something in the MBR on the first HDD"
 
#5
Do you mean this?

See Attachment...Also be advised that I changed some of the settings in "Add new entry" and I am sure I did it incorrectly. Sorry; Can I reset it so it reads for you properly? Thank you very much for your help.
 

Attachments

Last edited:

Terry60

Knows where his towel is.
Staff member
#6
That's the box I meant, which seems to be empty, so I don't know why "view settings" is showing boot device "D".
Click EasyBCD > File > Load System BCD and see if view settings stays the same.
 
#7
Hi Terry,

"Click EasyBCD > File > Load System BCD and see if view settings stays the same."

I have attached the snippet you requested after selecting "File"> "Load System BCD"

The two snippets "Terry 3" and "Terry 4" appear to show exactly the same information

Thank you once again

ranger72
 

Attachments

Terry60

Knows where his towel is.
Staff member
#8
Since there's a fundamental difference of opinion between the BCD and Disk Management about where the boot files are located, did your Linux installation take over the MBR on D ?
Is your boot menu being presented by grub ?
Give "System Reserved" a letter ("n") temporarily and
EasyBCD > File > Select BCD Store, then navigate to "n"\boot\BCD
If that shows boot drive "n" instead of D, it will indicate that the BCD on your W7 drive is intact (and not being booted directly)
If EasyBCD tells you that file's in use, then Select the BCD on "D" and see what it says is in there.

(Sorry about being long-winded, but I'm just trying to establish the true situation before giving premature advice)