Selected the wrong bcd store how can correct this?

#1
Hello guys,

I've used easybcd before for windows/linux dual boots.
It's a great piece of software.
I've run into a problem here though.

I've read the sticky and looked thru the posts
in particular one was similar... Access denied! unable to obtain exclusive access when exiting EasyBCD
but i've not worked this one out yet!

When I first ran easybcd on this machine i got BCD store not found.
Like the user in the thread i mentioned,
I then mistakenly sent it to the boot folder in \Windows\boot\...

Here's the overview:

There is one entry in the Windows bootloader.
Path: C:\Windows\Boot\DVD\PCAT\BCD

Default: Windows Setup
Timeout: 30 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Windows Setup
BCD ID: {default}
Device: [boot]\sources\boot.wim
Bootloader Path: \windows\system32\boot\winload.exe


so now the program won't close:

Unable to obtain exclusive access to C:\Windows\Boot\DVD\PCAT\BCD.
If this is a removable disk, try ejecting and re-inserting it and then try again.


I've been ending it from the task manager.
I'm using a grub disk to boot linux and the windows boot loader still works
but i'd like to use easybcd for a nice clean dualboot if possible.

The C partition is active
How can I load the bcd registry at C:\boot\bcd instead?
I've tried reinstalling the application but path remained the same.

Any help with this would be very much appreciated
Thank you

mintydan
 

mqudsi

Mostly Harmless
Staff member
#2
The "can't close" is a bug that's been fixed in the latest EasyBCD 2.2 beta: EasyBCD 2.2 Beta Builds
You can select a different BCD from File | Select BCD Store

If you're using 2.2 beta already (make sure you're using the latest), the autoload path can be changed from Tools | Options.
 

mqudsi

Mostly Harmless
Staff member
#4
Great to hear!