Share Quad Boot on 2 different HDs - Windows 10 & three linuxes

#1
OK here is my setup and how it resulted:

A Dell Studio Notebook that supports two separate sata physical discs.

I first installed Windows 10 rtm on a 500 GB HD with 2 partitions, one C for OS, other D for data. Usuall non efi install.
Then I removed that HD put in an 250 GB HD that i divided in the following partitions, common swap & home partitions, (swap and ext 4 file sys) THREE 50 GB ext4 partitions for three different linuxes: (al x64): LXLE 14.04, Sparky 4.0 KDE and Mint 17.2 XFCE, I installed them in that order "chainloading them". With that disc only in the notebook I TRIPLE booted the linuxes with grub

Then I put BOTH HDD in the notebook, setted Windwos disc as boot default and there I went.

After booting windows 10 (x64) I installed EasyBCD 2.3 Beta . Using add entries I added each one of the three linux partitions. I could not add the HDD even if Grub is installed on sda (main disk or something, I am sort of noob in linuxland)

After rebooting Windows shows me the 4 boot entries, but any of the linuxes I select boots to the same main grub menu, and from there I must select the linux I want to boot. It is sort of useless having the three linuxes if the menu just points to the same main grub

The other problem is that EACH time I reboot a linux OS I must wait till windows 10 boots nearly fully to the boot selection and then, select the os, and go all de way again.....

SUGGESTIONS, IDEAS?
 

Terry60

Knows where his towel is.
Staff member
#2
The windows 10 problem might be described here
Windows 8 (or 10) boot problems ? Please read this before posting
afaik, it's never been possible to boot multiple Linux from the BCD without resorting to a two stage boot via the grub menu, but it's been many years (pre grub2) since I had any practical experience with Linux, so my thoughts are not definitive.
 
#3
Terry, thanks, had read (quick reading :frowning: ) that post. Will see into Windows 10 "what the power button does" and be back.
The two stage boot via grub is just a bother, when I reboot from windows to one linux it goes down and restarts with the grub default, even if I selected other
When I set up easy bcd I selected each linux on its own partition, because on selecting the hard disk that cotains ALL three linuxes easybcd did not find anything... maybe I will just erase two entries in easybcd and just leave one called "Linux HD" or something,
Would be nice if there was a way of having just ONE boot menu from base startup with all oses on multiple disks.... just dreaming :wink:
 
#4
OK Terry, tried it out. Changing "what the power button does" may turn on a full shutdown in windows 10, I don't know how to test that. But what MAKES the difference is the "Use Metro bootloader" item, if not used boot menu appears really fast. If used, metro has to load and it takes longer....
 
#5
Well discovered other quirk or bug. Lets see, entre bios set system time to current gmt -3 (its 15:36 down here), boot to windows 10, time is OK, REBOOT to ANY Linux, time is 15:36, BACK to reboot, enter bios and TIME HAS JUMPED TO 18:36, THREE HOURS MORE.... ¿CAN GRUB OR EASYBCD bee setting time to GMT??????????????

-Windows rebooting to windows (no grub in the middle) does NOT change time
-Setting bios to correct time, boot into LXLE Linux, that shows the system time, correct time, reboot again entre bios, time has jumped (during shutdown and bios F2) three hours. LXLE is ther first linux I installed on that disk, Sparky and Mint came after, Grub is version 2.02 beta2-ubuntu1.3

Sparky and Mint DO NOT change time on reboot, maybe a LXLE bug?
This did NOT happen when the only disk in notebook was the linux disk with the same setup
It started to happen AFTER installing the Windows 10 disk with easy BCD. I dont know what is has to do but.....:confused:
 
Last edited:
#6
OK SOLVED THE clock change, it is an ubuntu quirk, LXLE is an derivative of ubuntu, here is the info:

" ... How to Prevent Ubuntu Linux from Resetting or Changing Computer’s BIOS or Hardware Clock
by Shivaranjan on June 20, 2009

When Ubuntu Linux and Windows are used together and if the time zone is not UTC and when the computer is rebooted into Windows after Ubuntu Linux is used the time gets changed as the BIOS clock gets reset to UTC. For example if the time zone that is set in Ubuntu Linux is GMT +5.30 hrs then after Ubuntu Linux’s usage the time in BIOS clock would be set to UTC time i.e. the BIOS clock would be +5.30 hrs behind the Ubuntu Linux’s time but if you boot into Ubuntu Linux it will automatically adjust to the local time where as the time on Windows will be the UTC time which can cause issues with Windows.

The difference is the way Ubuntu Linux and Windows handle time, Windows considers the BIOS clock of the computer to be the local time where as Ubuntu considers it as UTC time. To solve this we would have to set Ubuntu Linux to consider the hardware or BIOS clock as local time


How to Prevent Ubuntu Linux from Resetting or Changing Computer’s BIOS Clock
In the following steps you can find the steps to set the hardware clock as local time in Ubuntu.

1. Open the terminal and enter the following command:

sudo gedit /etc/default/rcS

2. In the gedit window that opens ups find the the line UTC=yes and change it to UTC=no..."
 
#7
As easybcd has no part in this latter problem (the problem is the different way OSes treat system utc time), administrators please feel free to remove non related post if you deem them no useful for the rest of the forum