Stuck at blinking cursor/underscore when booting into Windows 7

#1
Hey. I know I'm new here.. But I'm completely lost as to what I can do.

On monday, I was installing Ubuntu on a second partition, and, whatever happened, I ended up losing my entire hard drive. Even the partition table. I re-partitioned it using GParted, and, just today, I finished restoring a .VHD of Windows 7 using Acronis. I went to boot the computer, and, nothing happened. I went back into GParted, and spent half today moving the windows partition over 50GB, because, for some reason, there was 50GB of unallocated space to the left of the windows partition.

Anyways, I've just spent the past 3 hours trying various ways to get into windows.

I've done the whole diskpart thing, and made sure that my partition is set as active. I've done /fixmbr /fixboot /scanos /fixbcd. Twice. I've tried startup repair - It tells me nothing is wrong with my drive. I've even gone through the entirety of this: http://neosmart.net/wiki/display/EBCD/Recovering+the+Windows+Bootloader+from+the+DVD . Including doing the whole "create the MBR from scratch" thing.

Everything has yielded the same result. It goes through my BIOS, flashes the MSI graphic on the screen, and then sits at a blinking underscore. For, I'd say 10 minutes. Maybe a bit less.

After that, it says only:

A disk read error occured
Press Ctrl+Alt+Del to restart
And, if I restart, it just does it again.

I (was) running Windows 7 Pro x64. I have 16GB of RAM intalled. The only things currently plugged in are my Keyboard and mouse, and the monitor.

If possible, I'd really, really prefer not to have to re-install windows, but, obviously, I might be forced to if that's the only option...

If anyone has any suggestions, I'm willing to try anything.

Oh, and, startup repair's diagnostic output says that it booted the drive successfully. Which makes no sense to me, since, it obviously isn't booting.

Thank you in advance.

Neil Hanlon
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
I would use the command line and do a chkdsk /r on the drive. It sounds like there is an issue with the drive itself if it keeps losing the boot information right after you get the system working. There is no reason for that. The only other thing I could think of would be that after you do the restore, use EasyBCD and make sure to redo the boot information. It could be setup to the previous install and that is why it loses it. But a chkdsk wont hurt.