Ubuntu boot problem using EasyBCD

#1
Good afternoon,
For a long time I've been using EasyBCD to set the correct boot in a win7 and Ubuntu dual boot since I don't like the grub interface.
To set EasyBCD I generally follow this list:
- BCD Deployment
- I select the partition when Win7 is installed ( C: )
- Install BCD - Yes
- Add Entry: Win 7, name, C:
- Add Entry: GRUB 2, name, automatic
- Edit Boot Menu: save settings
- BCD Deployment: Write MBR

This procedure always worked fine until today when, rebooting my ubuntu partition an error appears:
Try (hd0,0): FAT32: No ANG0
Try (hd0,1): EXT2:
and the window remains stuck there.

So, using a Ubuntu Live CD I was able to repair the grub error using boot-repair (How to Repair GRUB2 When Ubuntu Won’t Boot)
After a reboot the GRUB appears after BCD window: if I select ubuntu it boots ubuntu, if I select Windows 7 it loads the BCD windows with both entries (Win 7 and Ubuntu). Anyway, I'm able to boot both window and ubuntu.
The problem is: if I repeat the above procedure with EasyBCD, that always worked fine, the error reappears and I have to repair again the GRUB.

I don't understand what generate that error that never happens before.

My BootMode is set as Legacy (I think) since the Bootloader Path in EasyBCD goes to "winload.exe", but I'm not sure about that.

Is someone able to fix that?

Thanks in advance!
 

Terry60

Knows where his towel is.
Staff member
#2
Do NOT "write MBR".
That's for fixing a broken boot and will just undo everything you did previously.
Add your entries and stop there.
 
#3
This not fix the problem. Exacly as before when I try to boot into Ubuntu appears:
Try (hd0,0): FAT32: No ANG1
Try (hd0,1): EXT2:
 

Terry60

Knows where his towel is.
Staff member
#4
Reading your list more carefully -
- BCD Deployment
- I select the partition when Win7 is installed ( C: )
- Install BCD - Yes
I notice you're using "Create Bootable External Media" (my emphasis), which as the name suggests is for creating a BCD on e.g. a thumbdrive. not on your system.
If you are installing Linux after Windows, you should firstly instruct the Linux installation not to write to the MBR but to install grub in a Linux partition and leave the Windows boot in control.
You can then add a Linux entry to the BCD to enable dual-booting via Windows bootmgr.
If you've allowed Linux to take control of the boot (which incidentally you must do if using a UEFI Windows PC - bootmgr cannot boot Linux under UEFI), and you wish to put Windows bootmgr back in control on a BIOS/MBR PC, then you should use the bottom half of the BCD deployment page
Install the Vista+ BCD/bootmgr
Write MBR
to put Windows back in control, then go to "Add New Entry" and add your linux entry to the restored BCD.
Stop at the "add entry" point.
Don't add entries first and repair the BCD later.
 
#5
Hello there,
I am sorry as I probably will not help sorting out your situation, but I have a similar problem. On my Why! 650 installed with Ubuntu 16.04, I installed Win7pro then with EasyBCD I created a Dualboot (GRUB2). When chosing Windows, it worked well but I had a similar message (than Giulio93) when I chose "Ubuntu" showing:
"Try (hd0,0): EXT2:". Then impossible the go ahead.
I try to fix the grub as GUilio93 did (How to Repair GRUB2 When Ubuntu Won’t Boot). I applied the grub2 on all partitions from Ubuntu DVD. The result beeing: when booting, I had the choice between: Ubuntu, Advanced option for Ubuntu, Windows 7(on/dev/sda2), windows 7(on/dev/sda3).
Ubuntu works fine.
Both Windows 7 are not working, even if they seems to start (Windows starting sound heared) but the screen is stuck on a purple background, impossible to do anything else than switching off the hard way. After that, from Ubuntu, the Windows partition is not accessible any longer a message specifying to resume Windows to shut it down "fully" (Windows is hibernating).
I tried to repair Windows booting from the Windows DVD, this without success.
So, it is not better than originaly.
Not sure somebody can help me (with so few computer knowledge)... but who don't try won't succeed.
Thanks