Unable to access files even with Easy RE

#1
Hi,

I've purchased EasyRE for Vista and tried, unsuccessfully, to fix my computer which (without EasyRE) can't even start up in safe mode (goes to windows repair and I end up with a large white cursor on a black screen)

EasyRE loads up and I've tried the automated repair option in Easy RE - but got the following message: "The selected partition is corrupted and could not be accessed or repaired. Please select a different drive to continue"

I also tried the partition repair option - and got the following message: "Could not get identity of device / dev/ada0 - Inapproprioate ioctl for device". When I click "ignore" it runs for a bit then gives me the following:

Check and repair file system (ntfs) on /dev/ada0s2
Calibrate / dev/ada0s2
path: /dev/ada0s2
start: 3074048
end: 625141759
size: 622067712 (296.62 GiB)

Check file stytem on /dev/ada0s2 for errors and (if possible) fix them
ntfsresize -i -f -v /dev/ada0s2
ntfsresize v2014.2.15 (libntfs-3g)
ntfs_attr_pread_i: ntfs_pread failed: Input/output error
Failed to read $MFTMirr: Input/output error
ERROR(5): Opening '/dev/ada0s2' as NTFS failed: Input/output error
NTFS is inconsistent. Runchkdsk /f on Windows then reboot it TWICE!
The usage of the /f parameter is very IMPORTANT! No modification was
and will be made to NTFS by this software until it gets repaired.

libparted messages
Could not get identifty of device /dev/ada0 - Inappropriate ioctl for device

I also don't know how to start the computer with a DOS -prompt (pressing F8 on start-up doesn't give me that option) so I can run chkdsk and the EasyRE DOS prompt doesn't seem to offer the chkdsk option.

Can anyone help? If I could even get onto my hard-drive to backup my files that would be something (the "Browse/Backup Files" option does not work either)

Thanks
 

Terry60

Knows where his towel is.
Staff member
#2

mqudsi

Mostly Harmless
Staff member
#3
Whatever it is, it seems to be caused be extreme filesystem corruption.
 
#4
Thanks for your suggestions, Mahmoud and Terry. I used AVG Rescue to access the files on my hard-drive. It wasn't able to repair the computer, but I've been able to access the files to back them up. However, it is a long and painful process, as the file download keeps stalling every 20 or 30 files and I have to manually opt to skip the file! I'm no expert but this seems to support Mahmoud's thoery that the hard drive is badly corrupted. Anyway, the computer was about 7 or 8 years old and would have needed replacing soon anyway, so I'm not that annoyed - at least I'm getting most of my files back.

Anyway, once again, thanks both for your suggestions.