Upgrade from XP to Win-7 killed dual boot to Ubuntu

I finally got around to upgrading my Acer desktop from XP to Windows 7. Prior to the upgrade I had a working dual boot setup with XP and Ubuntu (Ver 12.04) or thereabouts.

Not surprisingly, the upgrade messed up the dual boot set-up. But nothing I've tried has allowed me to re-establish my ability to boot into Ubuntu. The old Ubutu setup was still using the original Grub (not Grub2). The other thing that may be relevant is that this machine has a recovery partition. One of my attempts to get things configured properly resulted in the Ubuntu menu selection booting into the recovery partition.

I'm missing something somewhere. The notes on this site regarding dual booting Ubuntu are not much help. The frustrating thing is that I did the same sort of upgrade on a different machinea couple of years ago, using an older version of EasyBCD and had no significant problems, as far a I can remember.

So, what's the secret?


Knows where his towel is.
Staff member
You should be able to identify the Linux partition where you placed grub by its size in the drive dropdown menu on the Linux tab of "add new entry".
If it's on a different HDD to Windows, tick the box too, otherwise leave it empty.
Hi Terry,

Well, when I open the drive list on the Linux/BCD tab, I can see all of the partitions on the C: drive, and even the one partition on an external drive (non-bootable) shows up.
I selected the Linux partition, which was clearly identified in the list. Didn't check "Use EAasyBCD's copy of GRUB". Rewrote the MBR and I wind up two menu entries. The Win-7 selection boots up just fine. But the Ubuntu selection "reboots" to a black, entirely empty screen. No error messages, not even a flashing cursor.

The following is what I find in the detaild display under "View Settings":

Windows Boot Manager
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {4679fa91-8d08-11e3-8218-e9a678fa103f}
resumeobject {4679fa90-8d08-11e3-8218-e9a678fa103f}
displayorder {4679fa91-8d08-11e3-8218-e9a678fa103f}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 10

Windows Boot Loader
identifier {4679fa91-8d08-11e3-8218-e9a678fa103f}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {4679fa92-8d08-11e3-8218-e9a678fa103f}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {4679fa90-8d08-11e3-8218-e9a678fa103f}
nx OptIn

Real-mode Boot Sector
identifier {4679fa98-8d08-11e3-8218-e9a678fa103f}
device partition=C:
path \NST\nst_linux.mbr
description Ubuntu Linux


Knows where his towel is.
Staff member
"..Rewrote the MBR..." ??
You didn't go into the advanced menus, I hope.
Just "Add Entry" is enough.
No, I looked at the advanced settings out of curiosity, but didn't mess with anything there. All I did was add and entry from the Linux/BCD tab, pointing to the Ubuntu partition, and then from the BCD Deployment page, selected "Write MBR". Was that second step incorrect?

---------- Post added at 04:37 PM ---------- Previous post was at 03:12 PM ----------

In looking over the settings I included in my previous post, I noticed that in the section for the Real Mode Boot Sector, there was a path specified: \NST\nst_linux.mbr. I inspected the contents of that file and discovered the entire file is filled with zeros. Pretty clearly not what should be there.


Knows where his towel is.
Staff member
No, you definitely don't "write MBR".
That's on the page for reinstating the Vista/7/8 boot if it has been overwritten, or back-levelling to NTLDR if reverting to XP and totally abandoning BCD-based systems. (Not many people are likely to be reverting to XP this close to EOL, but EasyBCD still provides the historic option from the time when people were trying out Vista Betas)
Click on that, and you undo everything you did just before it.
Try deleting the Linux entry and add it again, but don't go any further than "add entry".
Still no joy so far. Tried several times, with the following results. Please note that following each experiment I'm editing the boot menu to remove the non-working attempt, and verifying from the View Settings tool, that the corresponding entry has been deleted. I also checked, and the nst_linux.mbr file in the Windows NST folder gets deleted each time.

So, from the Linux/BSD tab in the Add New Entry window, I can select among four choices:

Partition 1, which is the ACER recovery partition. If I pick that, the Linux boot menu choice takes me to the recovery partition. Not good

Partition 2, which is the Windows 7 C: drive. If I pick that the linux boot menu choice takes be right back to the boot menu screen again.

Partition 3, which is where Ubuntu is. If I pick that, the Linux boot menu choice brings be to a black, blank screen, as described previously. After
I made this choice, I checked to see what had been written in the NST folder, and found a nst_linus.mbr file that contains 512 zeros.

Partition 4, which is the Linux swap. Obviously don't want that.

In none of these cases have I tried selecting "Use EasyBCD's copy of GRUB", since somewhere in the on-line documentation it says that this selection is only applicable if Linux is installed on a different physical drive.

I took a look at my working setup on my laptop, and the EasyBCD settings window on that machine shows the bootloader path for the Linux menu selection as \NST\AutoNeoGrub1.mbr. That file is around 9kb long, and it isn't full of zeros.



Knows where his towel is.
Staff member
That laptop entry indicates a grub2 entry. Are you sure that your desktop didn't upgrade to grub2 at some point ?
What happens if you create a grub2 entry and let EasyBCD auto-detect ?
Well, that produced some progress, but not there yet. Picking GRUB 2 and leaving the drive selection at "Auto...." results in a boot to some sort of command screen. I found a long list of GRUB commands, including Boot, and Reboot. Boot didn't work but Reboot at least allowed me to return to the EasyBCD boot menu, from which I have no trouble booting into Windows. I did check to see what had been created in the NST folder, and found a AutoNeoGrub0.mbr file that is about 9kb long, and actually has something in it.

Regarding the possibility that some upgrade replaced the original GRUB with GRUB 2, I can't confidently say one way or the other. I was pretty convinced that I was still using the original grub, since I never had any contrary indication. I've been upgrading along with each release of Ububtu since at least version 8. Finally quit at 12.04 because I don't like their new "modern" GUI, and didn't want to put up with the hassle of having Ubuntu updates mess up my Windows boot.


Knows where his towel is.
Staff member
Well you've reached the limit of my Linux experience now, so hopefully someone else more current can help you. (I too upgraded Ubuntu using legacy grub from 8.? to 12.?, but gave up using it altogether years ago, so my grub2 experience is nil)
Well, appreciate your help in any event. I'm not ready to give up yet. I guess my next task is to read everything there is to read in the on-line documentation. My overall understanding of the mechanics of booting isn't the best.

I really think the program could benefit from a more concise help file that focuses on describing the purpose and effect of each control option in the various control pages. My original error of going to the BCD Deployment page resulted from my trying to use information in an on-line article in the documentation regarding setting up a dual boot with Ubuntu as a model. That article is based on two assumptions that were untrue for my situation. It assumed that Ubuntu was installed AFTER windows (and stated that if this wasn't the case, that the guide should be applied more "loosly" or something like that). And it assumed that the Ubuntu installation was using GRUB 2, which I still don't believe is true for my system.

I did run across another posting in this forum where someone else ran into the same GRUB (2?) command screen. Will have to rummage around and see if I can find it again.

Again, thanks for your attempts to help me get this straightened out.