Vista 32-bit + 64-bit dual-boot catastrophe

Discussion in 'EasyBCD Support' started by YoungChris, Aug 23, 2008.

  1. YoungChris

    YoungChris New Member

    Joined:
    Aug 23, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hi everyone, I came across this forum while looking for solutions to a disk boot failure that happened a few hours ago. The people on this forum sound knowledgeable so I'd like to ask for your help here.

    I recently bought a 640 GB drive to add to my system for installing 64-bit Vista. I already had a 320 GB drive running 32-bit Vista in my computer which I was planning on formatting and using as external storage after getting the new hard drive up and running with the 64-bit. When I installed it though, my system automatically became a dual-boot 32-bit + 64-bit Vista because I had the original hard drive connected while the new one installed. In my stupidity (and nonexistent experience with dual-booting) I proceeded to delete the partition of the 32-bit hard drive after I got the 64-bit one completely up and running exactly how I wanted it. I never realized that the MBR resided only on the first hard drive so the next time my computer restarted, I was greeted with DISK BOOT FAILURE!

    So my current situation:
    320 GB drive, former 32-bit Vista, deleted partition
    640 GB drive, 64-bit Vista with files intact, but no boot

    I tried the steps on Recovering the Vista Bootloader from the DVD wiki. But when I try the "bcdedit /createstore c:\boot\bcd.temp" step of Nuclear Holocaust, I get "store creation operation has failed." And now I'm stuck...

    Is it possible for me to create an MBR from scratch on the new drive? Is there anything else that you guys think I can do about this other than start all over? Thanks guys, all help is appreciated.
     
  2. Terry60

    Terry60 Coastline Designer Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    9,541
    Likes Received:
    1
    Trophy Points:
    38
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    Hi Chris, welcome to NST.
    Let Vista do the hard work for you.
    Disconnect the old drive, boot from the Vista64 DVD and select "repair my computer" / "repair startup".
    This will fix one thing at a time, until eventually the new Vista will boot unaided. (probably 2 or 3 DVD boots). Then reconnect your old HDD, making sure the new one is at the top of the BIOS sequence (and preferably on your 1st SATA channel), and you should be where you want to be.
     
  3. YoungChris

    YoungChris New Member

    Joined:
    Aug 23, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Thanks Terry, I disconnected the old drive and rearranged my sata connections so that the new drive was channel 0 master. When I click "Repair your computer" after booting the DVD, I don't see any operating systems listed and it gave me the option to load drivers or just click next. After clicking next and completing startup repair, the diagostic details say the root cause of the problem is that "the partition table does not have a valid System Partition" and that partition table repair was completed successfully. However, startup repair has run about 6 times now and the computer still boots from the DVD even though the hard drive is first in the boot order. When I take out the DVD and restart, disk boot failure happens on startup. Should I keep running startup repair?

    Addendum:

    I forgot to mention that the diagnostic details continue to show this root cause each time startup repair completes, which is taking about 3 seconds.
     
    Last edited: Aug 23, 2008
  4. Terry60

    Terry60 Coastline Designer Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    9,541
    Likes Received:
    1
    Trophy Points:
    38
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    It sounds like it needs the "system" flag to be set on your Vista partition, which I'm surprised the "repair" doesn't do. If you've got a 3rd party partition manager, you could try marking it as system active before trying the repair, or wait for Guru to advise if he knows whether it can be done from the recovery console.
     
  5. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,597
    Likes Received:
    4
    Trophy Points:
    38
    Location:
    Chicago
    You can do it from the command line:

    Code:
    diskpart
    sel disk 1
    sel part 1
    detail part
    This should print something like this:
    Code:
    DISKPART> detail part
    
    Partition 1
    Type  : 07
    Hidden: No
    Active: No
    
      Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
    * Volume 4     D                NTFS   Partition    112 GB  Healthy
    Then type:
    Code:
    active
    To make it the active partition.
    typing
    Code:
    detail part
    should display the same as above once more, but this time active = yes.

    Type
    Code:
    exit
    to quit the command-line partition manager.


    Note: the above assumes the Vista partition is the first partition (part 1) of the first drive (disk 1)
     
  6. seacombe2379

    seacombe2379 New Member

    Joined:
    Sep 29, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    im having the same fault got it a while back but sorted it but now its back and will not go even tried the guru's method and that didnt work all i get now is bootmgr missing
     
  7. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,597
    Likes Received:
    4
    Trophy Points:
    38
    Location:
    Chicago

Share This Page