Vista boots fine, Ubuntu crashes

#1
Hey all,

I was hoping someone might be able to shoot me in the right direction. I currently have a RAID 5 setup (mobo raid) and I have that raid devoted to vista. I have an IDE drive that I have ubuntu on but I have been unsuccessful in trying to get it to dual boot using easybcd. I followed the directions of clicking advanced during the ubuntu install and specifying hd(0,0) to install grub, and I even tried using the super grub CD to reinstall grub using the directions given on the linux setup page of this website.

When I try to boot into linux using the loader it screams and asks me to insert a system disk when trying to load ubuntu. Vista still works fine. Any ideas?

-Ryan
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Hi Ryan, welcome to NeoSmart Technologies.

Sounds like it might be your RAID screwing things up, try giving NeoGrub a shot.
Just add a new NeoGrub entry in EasyBCD, and set up the configuration file as shown in the documentation (NeoGrub - NeoSmart Technologies Wiki) to point to the correct drive and boot files.

A bit more complicated, but very reliable :smile:
 
#3
Thank you for your reply.

I tried using neogrub however I am still unsuccessful, but in a different manner. My vista loader works fine however when I select the ubuntu loader it brings me to the second loader screen and from there it fails with the error
Code:
filesystem type is ntfs, partition type 0x7
kernel /boot/vmlinuz-2.6.22-14-generic root=/dev/hdb1

Error 17: file not found
Here is a screen shot of my current partitions, and here is my current config section for linux. When I boot to ubuntu off of the live CD I can mount the IDE HD from /dev/hdb1

Code:
/dev/hdb1 on /media/disk type ext3 (rw,nosuid,nodev)
ubuntu@ubuntu:~$ cd /media/disk/
ubuntu@ubuntu:/media/disk$ cd boot
ubuntu@ubuntu:/media/disk/boot$ ls
abi-2.6.22-14-generic         initrd.img-2.6.22-14-generic.bak 
config-2.6.22-14-generic      memtest86+.bin
grub                          System.map-2.6.22-14-generic
initrd.img-2.6.22-14-generic  vmlinuz-2.6.22-14-generic
ubuntu@ubuntu:/media/disk/boot$
Code:
#This is our second entry
title        Ubuntu Gutsy Gibbon    
root        (hd0,0)       #Load Ubuntu from the 2nd harddrive's 3rd partition.
#Next Line: Translate (hd1,2) to Linux notation and set that as the root partition
kernel        /boot/vmlinuz-2.6.22-14-generic root=/dev/hdb1
initrd        /boot/initrd.img-2.6.22-14-generic
#End Ubuntu entry

#That's it!


Addendum:

ok I found my a solution, however I think it may be a bug...

I changed the hd in the neogrub configuration to use (1,0) despite what that pull down menu had stated and it now booted up and works perfectly!

Thank you for EasyBCD!
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
Interesting.

Your welcome, but perhaps you can help us debug this a bit?
Mind doing Useful Utilties | Power Console
Code:
bootpart.exe > c:\bootpart.txt
Then upload c:\bootpart.txt as an attachment?

Thanks!
 

mqudsi

Mostly Harmless
Staff member
#6
Thanks.

Is your 932GB hard drive the Linux one?
 

mqudsi

Mostly Harmless
Staff member
#8
ok, only thing I can think of is that you have some weird mapping going on where Vista sees its own drive as the primary/boot (and as such, drive 0) instead of in its proper position as drive 1.

:S