W7-WXP dual boot seperate drives "Windows cannot find file C:\ ....

W7 on drive SATA O
WXP on drive SATA 1

Dual boot works fine - can install program in WXP from a CD but downloaded a HASP driver file from Sentinel haspdinst.exe which require a switch that is typed "space -i " like this ... haspdinst.exe -i . This install worked fine before I did the dual boot using EasyBCD commercial verison and iReboot (I had installed W7 on one new drive using SATA0 connector , then disconnected and moved the HDD0 and SATA0 connectors to another new drive and installed WXP.

With WXP running before I did the dual boot , I was able to install using the switch . For other reasons I had to do a re-install of the WXP again starting from a completely reformatted drive . I then connected W7 drive to SATA 0 and the WXP drive to SATA 1 and EasyBCD auto set up the drives for dual boot and I installed EasyBCD /iReboot on both drives because I did not get any icon to change back to W7 from the WXP screen

But now when I try to install haspdinst.exe -i I get message that Windows "cannot find the file etc" I have tried from the USB stick , from the file unzipped in Hanks documents (admin) , If I leave the -i switch off , I get to the screen that tells me I have to add the switch to do the install - but then when I add the switch , Windows cannot find the file. I did exactly that way before the dual boot and it worked fine.

Any ideas ? I have worked for two weeks on this blasted dual boot to be able to run a very expensive circuit design program that absoutely refuses to run in W7 or in VNC/WXP inside W7 .

Thanks - Hank


Mostly Harmless
Staff member
EasyBCD doesn't really have anything to do with haspdinst.exe?