Win8 EasyBCD 2.2 issue...

I was working on getting Ubuntu installed on a bootable USB stick running on a Windows 8 laptop with UEFI and meeting with some success (not done yet). During the process, I must have made an error somewhere while I was working on it because I wound up with multiple entries in my HD boot loader, some of which referenced my Ubuntu grub. I downloaded and installed EasyBCD 2.2 due to a blog entry I read related to a similar issue. I was able to remove one of the "bad" entries but nothing I do can remove the other. I have tried making my changes and saving, backing up my changes then restoring them then saving, saving then rebooting, specifically running the system in admin mode and all prior things, nothing seems to work. I can not remove the other entry. I am left with two entries, one form Windows 8 (entry #2) and one for Ubuntu (entry #1). Any ideas or help is most appreciated. Thank you.

My system is Win 8 (64bit) on an Acer v3.

The settings look like:

There are a total of 2 entries listed in the bootloader.

Default: Windows 8
Timeout: Skipped
EasyBCD Boot Device: C:\

Entry #1
Name: HDD:
BCD ID: {a604cc28-9a0f-11e2-be8f-68942327b252}
Device: \Device\HarddiskVolume2
Bootloader Path: \EFI\ubuntu\grubx64.efi

Entry #2
Name: Windows 8
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.efi

Debug mode looks like:

Windows Boot Manager
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=\Device\HarddiskVolume2
path \EFI\Microsoft\Boot\bootmgfw.efi
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {fcab30df-fccf-11e1-84f7-b888e30d2d2a}
resumeobject {fcab30de-fccf-11e1-84f7-b888e30d2d2a}
displayorder {fcab30df-fccf-11e1-84f7-b888e30d2d2a}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 4294967295
displaybootmenu No

Windows Boot Loader
identifier {fcab30df-fccf-11e1-84f7-b888e30d2d2a}
device partition=C:
path \Windows\system32\winload.efi
description Windows 8
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {fcab30e0-fccf-11e1-84f7-b888e30d2d2a}
recoveryenabled Yes
isolatedcontext Yes
allowedinmemorysettings 0x15000075
osdevice partition=C:
systemroot \Windows
resumeobject {fcab30de-fccf-11e1-84f7-b888e30d2d2a}
nx OptIn
bootmenupolicy Standard
detecthal Yes
Last edited:


Mostly Harmless
Staff member
So what happens when you try to delete that entry?


Mostly Harmless
Staff member
Ah. Your BIOS (EFI, actually) asks the boot loader to re-add the entry. Have you tried timeout=0 instead of skipped?


Mostly Harmless
Staff member
Does your EFI "BIOS" have an option for timeout?