Windows 10 Compatibility

(I'm not sure if this is the correct thread, so please move this topic if necessary)

I have recently upgraded my W8.1 installation (single-boot) to W10 through Windows Update. Up to this point, I have had no need to install any other operating system, but for reasons that could be expanded into a 90 minute rant on Sony Creative Software product trial periods, I have the need for a Linux distribution.

I have previous experience with Linux and dual-booting, but have been purposely avoiding the topic for this machine since I strongly dislike how GRUB looks and works, especially when compared to the W8 boot manager. However, I can no longer avoid the subject, but I refuse to settle for the unsightliness of GRUB.

I would love to use EasyBCD, but I'm not entirely confident in it's compatibility with W10. Of course, if it worked with W8, it probably should work with the new release of Windows, but considering how many things were changed under the hood in Windows 10, making such assumption would not be the wisest thing.

So I ask this: has anyone used EasyBCD on Windows 10 (post-installation) before, and how did it go? What, if anything, didn't work? Are there any precautions I should take when using EasyBCD?


(Edited to fix atrocious typo right at the beginning of the post, as well as a punctuation mishap)
I've downloaded and installed build 199, but when I run it, I get a message saying:
"EasyBCD has detected that your machine is currently booting in EFI mode. Due to limitations set by Microsoft, many of EasyBCD's multi-booting features cannot be used in EFI mode and have been disabled."

When I click the button to pull up the limitations page (since I'm looking at using a VHD to boot), it sends me to, which just says "Invalid request, link not found!". Where can I find the information mentioned in the pop-up message?


Mostly Harmless
Staff member
Hmmm, I'll look into the broken URL.
However, the important thing is that ever since EFI/Win8, you can't really boot into a non-Windows/MS OS from the Windows EFI boot menu. If you must, you'll need to set GRUB2 (for example) as the primary bootloader and chainload Windows from there.

The alternative is to boot your PC in legacy/MBR mode; then you can dual-boot to your heart's content with EasyBCD and co.
I tried changing my boot settings to use Legacy mode, but when I restarted my computer with the new settings, this message was all I got: I confirmed that the internal hard drive was the first item on the boot order list, but that did not solve the problem. Once I returned to secure boot mode, all was good again.

I'm not sure if this is related, but I happened to notice that this was my hard drive partition layout, as shown by GParted: I'm unsure if the topics are related, but considering "UEFI" is often paired with "GPT" (a partition table format), I thought there may be a correlation. I understand that one common old partition table type (I want to say the "MS-DOS" type, but I'm not sure) has a partition count cap that is much lower than the number of partitions on the system, so is it possible that might be the cause of the error?