Windows 7 won't boot, cycles back through POST screen repeatedly

#1
Ok, so here is a long story short: I had Windows 7 installed on my computer's C: drive. I also installed Ubuntu "inside" Windows, but on a separate partition (L:smile:. Things were running fine, however I wanted to attempt to create another partition (W:smile: and install a copy of Windows 8. I never actually got to install Windows 8 though, because after creating the third partition my computer wouldn't boot to Windows 7 anymore. All I get is the POST screen and it reboots repeatedly and very quickly. I am able to boot to the Windows 7 installation disc and it searches and finds my Windows installation which is a good thing. However I am prompted without doing anything and it says: Windows found problems with your computer's startup options. Do you want to apply repairs and restart your computer? The details are long and says Name: Windows Boot Manager. Identifier: {long GUID here} .... The following startup options will be added. Name: Windows Recovery Environment (recovered), Path ... Windows Device: Partition=C... and it created a copy of the current boot config. If I choose yes, it reboots, but nothing is fixed and it loops to POST. When I boot to the CD again I get the same message. This time if I choose no, I am able to get to the different tools on the CD. I have tried chkdsk, fixboot, fixmbr, etc...I even tried the "nuclear holocaust" method which I know I have used in the past and it worked great, however this time it did not work. I know the hard drive is good because I was able to wipe the Linux partition and install Ubuntu back again, however I wasn't able to get to or see the files on my OS Windows 7 drive for some reason. Interestingly enough, when I installed Ubuntu it knew Windows 7 was also installed on the computer, and when it was done I got the GRUB bootloader, and it had Windows 7 in the list, but when I tried to go into it I just got a blinking cursor forever and nothing else. I hope this information is helpful and maybe someone can point me in the right direction to get this working again without having to wipe and do a reinstall. Thanks! (PS sorry for this long rant, I wanted to put spaces in but it seems I can't hit Enter to go to the next line?)