Windows 7 x64 and Ubuntu 12.04 x64

#1
Greetings! I am writing my first post and am brand new to this forum so please forgive me if I ask anything that has already been addressed. I did search several time to avoid starting a double thread.

I have Windows 7 x64 Installed on one HD and setup and EXT4 Primary partition for Ubuntu 12.04 x64 during installation. I cannot seem to get the dual boot menu to pop up. I followed several posts to add new entry for Grub 2, then named the Ubuntu OS. Device is (automatically configured). When I checked the setup, its showing:

here are a total of 2 entries listed in the bootloader.


Default: Windows 7
Timeout: 30 seconds
EasyBCD Boot Device: C:\


Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe


Entry #2
Name: Ubuntu 12.04 LTS
BCD ID: {6bc2c970-f099-11e0-9eb3-ad61b2ae433b}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub1.mbr

The drive letter for Ubuntu is not C:\
Windows does not recognize it, only the partition on the 2nd hard drive if I go to admin tools in Windows, but still no drive letter.
I checked several times and the drive letter should be H, but this is not an option to select in advanced settings for this OS.
Could someone please direct me as to what I am doing wrong? When I reboot, Windows 7 boots normal and there is not an option to select Ubuntu. This was never an issue until the latest update.
I am using EasyBCD 2.1.2 to set this up.

Any help would be greatly appreciated! \^_^/
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
The drive letter is only necessary for the BCD location of NeoGRUB. It has nothing at all to do with the actual drive location of Ubuntu. In fact Ubuntu doesn't use drive letter association like Windows. So it wouldn't be that at all, it would be the Boot ID, as that is the UUID of the drive.

So when you installed Ubuntu did you install GRUB2 to the MBR or to the partition? If you installed it to the MBR then you should only have to delete the Linux entry in EasyBCD and let it auto detect the entry. If you did not install it to the MBR and installed it to the / or /root or /home use have to manually select that partition yourself using the drop down menu.

Again there is no need for drive letters!!!! That is a Windows ONLY thing.
 
#3
Actually, that's exactly what I did. Most likely because I am still learning the linux file system. I installed it to the partition or / to be exact. Where can I select this in EasyBCD?

Addendum

I think i may have located what you are referring to. Under: Create Bootable External Media, there is a drop down to select the Linux Partition, with a button to Install BCD. Is this what I should select? If so, do I still need to have Ubuntu added via Grub 2 in the Boot menu?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#4
What I am saying is this. Ubuntu uses GRUB2 now. So you change the setting to GRUB 2 and you see this:

ebcdsettings1.PNG

Notice where it says Automatically locate and load? That is actually a drop down menu. Here you must know where you installed the GRUB2 files. Just click on it and you see this:

ebcdsettings2.PNG

Granted mine is going to look different for several reasons. 1. I dont have Ubuntu installed currently. I backed it up to test Win8. 2. I most likely have more hard drives and partitions.

But the point is still the same. You use the drop down menu to locate the EXT4 partition that you installed Ubuntu onto and select that. It will then load that into NeoGRUB. So when you reboot what you will see is the option to select either Windows or Ubuntu. Once you select Ubuntu you will get the normal Ubuntu GRUB Menu. You will have to bypass the actual GRUB menu by modifying GRUB from within Linux.
 
#5
I seem to be having the same problem. I have done what was recommended repeatedly and keep getting taken to the GRUB4DOS prompt with grub> and a blinking cursor.

Is there a command that will allow me to just boot my ubuntu install from the GRUB4DOS window?

My drive is setup up like this:

0 - windows bootloader ntfs
1 - windows partition ntfs
2 - ubuntu bootloader ext4
3 - root ext4

I tried some commands that I found on another forum but couldn't seem to get anything to work.

When issue an "ls", I seem to be in the windows root.

Help would be greatly appreciated. I know that I have the install setup in the order that I listed, which should be the correct way, because I booted a livecd and found the corresponding files in their correct places.

Addendum

Also, I tried both the stable and beta versions of easybcd in order to test for any updates that might have fixed the problem.