Windows 8.1 dual boot on one disk with UEFI bios

Discussion in 'EasyBCD Support' started by gogoud, Mar 5, 2014.

  1. gogoud

    gogoud New Member

    Joined:
    Mar 5, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    England
    I have a new Lenovo Idea Flex 15 laptop and I would like to maintain a backup partition on the same disk (as it has lots of space). I shrank the main partition and then created a new partition with a backup of the system using Casper 8.0. Then I used EasyBCD 2.2 to set dual-booting so I could choose whether to boot the normal or the backup partition. But although I get the choice, and the normal partition boots fine, the backup system hangs when I try to boot to it.

    This is the DISKPART info:
    DISKPART> list partition

    Partition ### Type Size Offset
    ------------- ---------------- ------- -------
    Partition 1 Recovery 1000 MB 1024 KB
    Partition 2 System 260 MB 1001 MB
    Partition 3 OEM 1000 MB 1261 MB
    Partition 4 Reserved 128 MB 2261 MB
    Partition 5 Primary 214 GB 2389 MB
    Partition 6 Primary 50 GB 216 GB
    Partition 7 Primary 25 GB 427 GB
    Partition 8 Recovery 13 GB 452 GB

    DISKPART> list volume

    Volume ### Ltr Label Fs Type Size Status Info
    ---------- --- ----------- ----- ---------- ------- --------- ------
    Volume 0 C Windows8_OS NTFS Partition 214 GB Healthy Boot
    Volume 1 E Windows8 Ca NTFS Partition 50 GB Healthy
    Volume 2 D LENOVO NTFS Partition 25 GB Healthy
    Volume 3 WINRE_DRV NTFS Partition 1000 MB Healthy Hidden
    Volume 4 SYSTEM_DRV FAT32 Partition 260 MB Healthy System
    Volume 5 PBR_DRV NTFS Partition 13 GB Healthy Hidden

    So C is the 'normal' system and 'E' is my backup partition (D and the rest are pre-existing stuff I don't understand).

    So when I try to add a boot entry with EasyBCD it is really easy and this is the result (debug mode):
    Windows Boot Manager
    --------------------
    identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
    device partition=\Device\HarddiskVolume2
    path \EFI\Microsoft\Boot\bootmgfw.efi
    description Windows Boot Manager
    locale en-US
    inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
    default {035536bc-a425-11e3-be79-a4db30848247}
    resumeobject {035536bb-a425-11e3-be79-a4db30848247}
    displayorder {035536bc-a425-11e3-be79-a4db30848247}
    {035536b9-a425-11e3-be79-a4db30848247}
    toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
    timeout 3

    Windows Boot Loader
    -------------------
    identifier {035536bc-a425-11e3-be79-a4db30848247}
    device partition=C:
    path \WINDOWS\system32\winload.efi
    description Windows 8.1
    locale en-US
    inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
    recoverysequence {035536bd-a425-11e3-be79-a4db30848247}
    recoveryenabled Yes
    isolatedcontext Yes
    allowedinmemorysettings 0x15000075
    osdevice partition=C:
    systemroot \WINDOWS
    resumeobject {035536bb-a425-11e3-be79-a4db30848247}
    nx OptIn
    bootmenupolicy Standard

    Windows Boot Loader
    -------------------
    identifier {035536b9-a425-11e3-be79-a4db30848247}
    device partition=D:
    path \Windows\system32\winload.exe
    description Windows 8 Casper_Backup
    locale en-US
    osdevice partition=D:
    systemroot \Windows
    nx OptIn
    pae Default
    sos No

    I notice that the settings for my D:/Volume1 loader are different from C:/Volume0 and I don't know why they should be since it is meant to be an exact copy of C:, but this is what EasyBCD did when I told it to add a Windows Vista/7/8 entry.

    What am I doing wrong and is there a way to get real dual-booting on this system? I don't believe there is anything wrong with the backup partition, I have used Casper successfully on many other machines, I think the boot process is not handing over to it correctly. Thanks for any help.

    Dominic
     
  2. Terry60

    Terry60 Knows where his towel is. Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    10,238
    Likes Received:
    60
    Trophy Points:
    48
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    Delete the new entry and add it again, specifying "E" for the disk.
     
  3. gogoud

    gogoud New Member

    Joined:
    Mar 5, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    England
    Thanks Terry I tried that but it still doesn't work. Why does this entry have a path to winload.exe whereas the C: (original) entry has a path to winload.efi? It doesn't look right to me...
     
  4. Terry60

    Terry60 Knows where his towel is. Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    10,238
    Likes Received:
    60
    Trophy Points:
    48
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    Sorry, I missed that when I saw the wrong disk letter.
    You're right, it should be efi.
    I'll leave it to CG (the author) to comment on why EasyBCD is creating on non-efi entry for your cloned partition.
     
  5. gogoud

    gogoud New Member

    Joined:
    Mar 5, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    England
    So I used bcdedit (ugh!) to edit the line:
    Code:
    path \Windows\system32\winload.exe
    to read:
    Code:
    path \Windows\system32\winload.efi
    and now this partition runs ok
     
  6. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    14,340
    Likes Received:
    33
    Trophy Points:
    48
    Location:
    Chicago
    This is a known bug that's been patched and is due to be fixed in the next EasyBCD release. Sorry!
     
  7. Jim Walker

    Jim Walker Member

    Joined:
    Apr 22, 2012
    Messages:
    174
    Likes Received:
    5
    Trophy Points:
    18
    Encountered this problem too. Any estimate on when next EasyBCD release with patch will be available.
     
  8. eisenringtheo2

    eisenringtheo2 New Member

    Joined:
    Nov 14, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Meanwhile, when running UEFI Windows, you can duplicate the UEFI Bootloader in an elevated command prompt:
    bcdedit /copy {current} /d "Other OS"
    and then change the new entry easily in EASY BCD.
    Theo
     

Share This Page