Wrong drive letter

#1
Awaiting Windows 10 I want to have my Windows 7 installation for a first trial period.
I cloned my partition to a logical drive in the same HD. I used easyBCD to create a dual boot.
But now the clone starts as drive F: and this is fatal, since all the registry entries and programm links go to C:
A similar problem came up in this forum, but this was with a separate HD.
Is there any way to make the partition with the original OS unvisible before the clone starts, so it would get the first free boot letter C:?
If I would install a new system in a partition of that disk, both systems would start as C:
See my bcdedit status attached.
 

Attachments

Terry60

Knows where his towel is.
Staff member
#3
Or use a different technique to make the clone, which doesn't alter the OS drive letter.
(If you've used a "clever" cloning program which modifies the registry, it should have changed all those other references you're worried about- have you actually checked, or are you just assuming things will fail ?)
 
#4
Everything you need to change is in the MountedDevices registry key:
http://diddy.boot-land.net/firadisk/files/mounteddevices.htm
chest-hit! Last night I was too afraid to tamper with the registry. This morning with fresh power: I did it and deleted some registry entries and everything is working fine.
Thank you. I was looking for a solution for 2 days already.

@Terry60
First I used an intelligent cloning programme (HDClone) with the result that I could not boot the clone. Then I used the stupid Gparted with no corrections and thanks to mqudsi I was able to solve the problem with a low-invasive surgical cut. :smile: