Page 1 of 2 12 LastLast
Results 1 to 15 of 30

Thread: error message when trying to boot PC-BSD

  1. #1
    Join Date
    Mar 2010
    Posts
    34

    Default error message when trying to boot PC-BSD

    hello,

    I use Easybcd 2.0 to multiboot Win7 and PC-BSD.
    When I try to boot PC-BSD I only see a message Boot error and nothing happens.

    Anyone a idea how to solve this ?

    Roelof

  2. #2
    Join Date
    Mar 2010
    Posts
    34

     

    Hello,

    Really nobody
    Really disappontointing.

    Roelof

  3. #3
    Join Date
    Jul 2006
    Location
    The Source
    Posts
    4,270

     

    Win7, Ubuntu and PC-BSD? - The NeoSmart Forums

    Did you read through all the things I have posted? Just adding an entry for BCD allows PC-BSD to boot. If it doesnt boot that is not an issue with EasyBCD but the install of PC-BSD.

    I know this works cause I have done it personally and tested it myself.
    ~Alex~ .:Forum Moderator:..:Guinea Pig for Testing:.
    I do not accept support questions via EMail, PM, IM or my Spaces page! .
    This is what happens when an unstoppable force meets an immovable object.




    All your posts are belong to NeoSmart!!

  4. #4
    Join Date
    Mar 2010
    Posts
    34

     

    Yep.

    I did all the steps
    Did you also test it with V9. In the tutorial only v7 is mentioned.

    Roelof

  5. #5
    Join Date
    Jul 2006
    Location
    The Source
    Posts
    4,270

     

    I dont see any V9 for PC-BSD. The last stable release of PC-BSD is Version 8.2 as per their website. So using Beta software is not something that we can control if issues arise. They could have easily made changes to the software to cause this. Only they can answer such questions.

    EasyBCD only adds entries to the boot menu for the various OS's out there. Other than that it has nothing at all to do with how the OS or system operates. This is an issue with PC-BSD and has to be taken up with them.

    If EasyBCD was to blame you would get the error "OS not found press Ctrl+Alt+Del to restart" and you would then get brought back to the boot menu. Since you are only getting a boot error message this can only be the result of PC-BSD.

    Did you have a stable and working install of PC-BSD 9 before you restarted and added it via EasyBCD? I never used version 7 either. I only used Version 8.1 of PC-BSD.
    ~Alex~ .:Forum Moderator:..:Guinea Pig for Testing:.
    I do not accept support questions via EMail, PM, IM or my Spaces page! .
    This is what happens when an unstoppable force meets an immovable object.




    All your posts are belong to NeoSmart!!

  6. #6
    Join Date
    Mar 2010
    Posts
    34

     

    When I disable the disk with Windows PC-BSD wil boot
    I have contacted the developers of PC-BSD but they say they don't have any idea what this causes so Im looking further for answers

    Roelof

  7. #7
    Join Date
    Jul 2006
    Location
    The Source
    Posts
    4,270

     

    So your using multiple drives and not just multiple partitions. That is kinda need to know information. Not something you want to omit.

    Have you tried the latest build? Version 2.1 was just released today and it allows you to select PC-BSD as well as the drive/partition that you have it installed to.

    Along with this did you install the PC-BSD Boot Loader to the MBR or did you install it to the drive that it is installed upon?
    ~Alex~ .:Forum Moderator:..:Guinea Pig for Testing:.
    I do not accept support questions via EMail, PM, IM or my Spaces page! .
    This is what happens when an unstoppable force meets an immovable object.




    All your posts are belong to NeoSmart!!

  8. #8
    Join Date
    Mar 2010
    Posts
    34

     

    Oke,

    I apolize for that.
    I will try version 2.1 and hope that will work,
    I install pc-bsd bootloader to the MBR as far as I know.

    Roelof

  9. #9
    Join Date
    Jul 2006
    Location
    The Source
    Posts
    4,270

     

    Alright that could be the issue then. You might have to redo the install of PC-BSD and have it not write the boot loader to the MBR but to that drive. Then add an entry for PC-BSD using EasyBCD.

    The issue is 2 fold. PC-BSD doesnt use a standard boot loader. For the longest time they used the BTX loader which wasnt supported by anyone or anything let alone PC-BSD. We contacted them a long time ago to try and get support for their OS to use with EasyBCD for as far back as i remember.

    Now they switched to what I can only assume is the FreeBSD loader. I still dont know, nor can confirm my suspicion on this with them cause my question has gone unanswered for the longest time. To make matters worse, they have now removed the EasyBCD guide from their Wiki. Showing that they dont want to have their OS installed along side of any others.

    If we could talk to one of the Dev's and find out what boot loader they are using and how it operates I am sure that Mahmoud could code EasyBCD to work properly with PC-BSD. Until then not installing the loader and just creating a FreeBSD entry is all we can suggest for a fix.
    ~Alex~ .:Forum Moderator:..:Guinea Pig for Testing:.
    I do not accept support questions via EMail, PM, IM or my Spaces page! .
    This is what happens when an unstoppable force meets an immovable object.




    All your posts are belong to NeoSmart!!

  10. #10
    Join Date
    Mar 2010
    Posts
    34

     

    Hello,

    I left a message for the developers to talk to you or another person of your company.
    Hopefully we get this sorted out quickly.

    Roelof

  11. #11
    Join Date
    Jun 2011
    Posts
    1

     

    The way we are doing installs on PC-BSD is to use the "MBR" loader only if the user clicks to install it from the GUI. This loads the standard freebsd /boot/boot0 MBR loader with the following command:

    # gpart bootcode -b /boot/boot0 /dev/ada0

    The only other time we do something like this is if you select GPT as the disk-scheme, in which case we load the protective MBR:

    # gpart bootcode -b /boot/pmbr /dev/ada0

    Do you remember when you did the install if you chose to use the GPT scheme? That would make a huge difference here I'm sure.

    Also, we do still have the EasyBCD section in our handbook:

    Dual Booting - PC-BSD Wiki

  12. #12
    Join Date
    Mar 2010
    Posts
    34

     

    hello,

    I did not use the GPT mode. I only checked the install boot loader.
    For me it's install in /dev/ada1 because I use two disk and pc-bsd is installed in the second disk.

    Roelof

  13. #13
    Join Date
    Jul 2006
    Location
    The Source
    Posts
    4,270

     

    That option must have change. I remember I had to specifically check the box to UNdo the use of the MBR and have it install to the drive itself. Now you say that they have to check the box? So that has definately changed since I installed 8.1 not long ago.

    The reason why I say EasyBCD was removed, is cause the only other entry I seen for it was deleted:

    http://wiki.pcbsd.org/index.php/Dual..._Using_EasyBCD

    No forwarding or anything. Just the page was deleted. How are we supposed to know it was added into another Wiki Page?

    Hopefully something can be figured out. Cause I am at a loss. It worked perfectly for me with the steps I outlined in the first link I posted.
    ~Alex~ .:Forum Moderator:..:Guinea Pig for Testing:.
    I do not accept support questions via EMail, PM, IM or my Spaces page! .
    This is what happens when an unstoppable force meets an immovable object.




    All your posts are belong to NeoSmart!!

  14. #14
    Join Date
    Apr 2006
    Location
    Chicago
    Posts
    13,379

     

    It's now located here:

    Dual Booting - PC-BSD Wiki
    Mahmoud Al-Qudsi, Director



    I'm sorry but I do not accept support requests via IM, email, or personal messages

    Follow us on twitter @neosmart or on Facebook!
    Like us on facebook!

  15. #15
    Join Date
    Jun 2011
    Posts
    4

     

    Some users were experiencing problems with GPT so we changed the default back to MBR for 9.0. We've had other users successfully dual-boot on two separate drives and have a mailing list thread started by roelof:

    http://lists.pcbsd.org/pipermail/tes...ne/005385.html

    Is it possible for someone on the EasyBCD side to try to recreate this using 9.0 and report back? If so, testing snapshots are available from:

    ftp://ftp.pcbsd.org/pub/snapshots/

    and Sections 3 and 4 of the 9.0 Guide are available at:

    PC-BSD 9 Handbook - PC-BSD Wiki

    Like 9.0, they are a work in progress but the installation section is fairly up-to-date with 9.0's current features.

    If it is a FreeBSD bug, we'd like to get it sorted before 9.0 is released.

Similar Threads

  1. PC-BSD on second HD, boot fails
    By LuNa in forum EasyBCD Support
    Replies: 0
    Last Post: April 13th, 2011, 04:24 AM
  2. Win7, Ubuntu and PC-BSD?
    By Mak 2.0 in forum EasyBCD Support
    Replies: 9
    Last Post: February 28th, 2011, 09:23 PM
  3. newbie wants to triple boot - Win7, Dt-BSD, & PC-BSD
    By donnybb in forum EasyBCD Support
    Replies: 1
    Last Post: May 13th, 2009, 02:45 PM
  4. EasyBCD and support for PC-BSD?
    By Mak 2.0 in forum EasyBCD Support
    Replies: 0
    Last Post: March 12th, 2009, 06:13 PM
  5. Vista / PC-BSD 7 / EasyBCD
    By Braveheart_BSD in forum EasyBCD Support
    Replies: 15
    Last Post: October 25th, 2008, 09:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •