Chainloading into GRUB2 bootloader fails - dropped into GRUB4DOS prompt


I've had a dual boot setup of Win 7 32 bit and Arch Linux 32 bit on my Samsung N150. Using EasyBCD to add Linux entry to chainload into GRUB2 via Windows bootloader. This has worked successfully for me.

Recently I wanted to upgrade Arch Linux from 32 bit to 64 bit. So I deleted Arch Linux partition and swap. Made new partitions. Formatted partitions. Installed Arch Linux 64 bit.

Went into EasyBCD, deleted old linux entry. Added new entry. Reboot. Select new Arch Linux entry, and I'm dropped into GRUB4DOS prompt. Here's a pic from someone else, but it's exactly what I'm looking at except I have GRUB4DOS 0.4.5c and a different date, mem, and end.


I've tried deleting the entry, rebooting multiple times, and then adding the new entry. Didn't work. I've tried downgrading to 2.2. Didn't work. I tried installing neogrub. Didn't work.

A few other things I've noticed while in GRUB4DOS prompt:

When I type find /boot and use tab completion to get list of options. I get Error 14: Filesystem compatibility error, cannot read whole file

I'll get this issue when using tab completion for any file. Even find / + tab will give me Error 14.

If I type kernel /boot/grub/i386-pc/core.img and hit enter I get Error 13: Invalid or unsupported executable format.

My entire linux is on one ext4 partition.
When booting up Arch Linux live cd. In the bootloader menu I'm able to select Boot existing OS and it will boot me into the GRUB2 bootloader and I can boot into the Arch Linux install successfully.
It's been about 2-3 years since I've done my original setup described at the start.

Can you help me figure out why it can't find my GRUB2 bootloader when it worked successfully on the same setup in Arch Linux 32 bit? Is there a debug log of some kind I can bring up somehow to tell me what it's doing, and where it's failing?