Dual Boot Problem

Discussion in 'EasyBCD Support' started by Das Boot, Oct 25, 2012.

  1. Das Boot

    Das Boot New Member

    Joined:
    Oct 25, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    I tried to dual boot Win7 and Mint13 and ran into a problem.


    One note – I tried to install XFCE MINT13 and I stopped it before it had completed. The status of the install was nonexistent and I didn’t know it hadn’t completed. I then used EasyBCD to update the Win MBR and added a Mint boot option using EasyBCD. I received this error instead of booting into Mint:

    “Windows failed to start. A recent hardware or software change might be the cause.

    File:\NST\AutoNeoGrub.mbr

    The selected entry could not be loaded because the application is missing or corrupt.”


    To repeat - that error occurred when I tried to boot Mint, not Windows.

    I then went to EasyBCD, deleted the Linux Mint line and uninstalled EasyBCD. I then went back and re-installed gnome Mint13 (I wanted this version more). I then installed EasyBCD and followed the instructions again.


    I ended up with the same error when I tried to load Mint13.

    Also, I can boot into Windows just fine. It is only Mint that is giving me problems.

    The basic dual boot tutorial that I followed is here:

    How to dual-boot Linux Mint 13 Cinnamon/MATE and Windows 7

    TIA…
     
  2. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,844
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Chicago
    Is this an EFI machine?
     
  3. Das Boot

    Das Boot New Member

    Joined:
    Oct 25, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Computer Guru, yes, it appears it is an EFI machine per this internet posting...

    installation - How to fix: Ubuntu 12.04 reboots after loading with elilo - Ask Ubuntu

    Thanks for the lead.

    I will "hit the net" and try and figure out how to dual boot EFI, but if you have a favorite link or some quick information, it is appreciated.

    Das Boot

    Addendum

    CG,

    I tried disabling EUFI boot options and going with a Legacy Boot, but I ended up with "...[some text, can't recall] DHCP" and the spinning slash that leave periods as it progresses.

    What would happen if I disable EUFI boot and reinstalled Linux Mint based on the Legacy Boot? I think installing Mint with EUFI enabled might be the reason why Mint doesn't load when I switch to Legacy Boot.

    I this works, would I be able to enable EUFI and then boot directly into Windows or would the Legacy Boot Mint install mess up my ability to boot into Windows?

    I also found these instructions...

    http://askubuntu.com/questions/151693/configure-dual-boot-windows-7-and-ubuntu-12-04-with-or-without-efi

    Is there a more intuitive and elegant solution than listed in the tutorial? If not, which approach in the tutorial seems to work the best?

    TIA...
     
  4. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,844
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Chicago
    At the moment, the best solution for multi-booting Windows & Linux is to disable EFI and have both running without it.
    With EFI, your only option (at the moment) is to have GRUB2 the main bootloader (vs BOOTMGR).
     
  5. Das Boot

    Das Boot New Member

    Joined:
    Oct 25, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Hi CG, I used EasyBCD to use Legacy Grub and disabled my EUFI. I received the following error...

    "Client MAC ADDR:...
    DHCP... [little spinning image that leave periods behind it]

    Do I need to reinstall Mint after I've disabled EUFI?

    Is there a tutorial link you can provide that covers the dual boot method that you recommend?

    TIA...

    Addendum

    I tried disabling my BIOS boot to see if I could get Mint to boot in UEFI mode, but no luck. I disable UEFI completely, but nothing will boot at all - it doesn't recognize the Mint CD. Argh... so many nightmares with so few solutions.
     
  6. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,844
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Chicago
    That's what I mean. You need to disable UEFI entirely. But to do so, you'd have to reconfigure the way Windows itself boots.
     
  7. Das Boot

    Das Boot New Member

    Joined:
    Oct 25, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    CG, I want to completely disable UEFI to boot into Mint. When I want to boot into Win7, I have no problem enabling UEFI.

    However, I haven't been able to load Mint13 or Ubuntu 12.10 even when UEFI has been disabled.

    One reason might have to do with the fact I didn't create a "Reserved BIOS Boot Area". A warning was given during installation that this might cause boot problems.

    The reason I haven't included that is 1. the tutorials I followed didn't mention it and 2. I'm a bit concerned that might screw up the Win7 boot process.

    Do you know if creating this "Reserved BIOS Boot Area" will or will not have an impact on the Win7 boot process?

    TIA...
     
  8. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,844
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Chicago
    You can't do it that way. UEFI has to be either off completely or on completely.
     

Share This Page