EasyBCD 1.7.2 unhandled exception when adding Wubi entry

#1
When I was trying to add a wubi entry for Ubuntu, I get this,

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.
************** Exception Text **************
System.ArgumentOutOfRangeException: Index and count must refer to a location within the string.
Parameter name: count
at System.String.Remove(Int32 startIndex, Int32 count)
at ..(String , String )
at ..(String )
at ..’(Object , EventArgs )
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3074 (QFE.050727-3000)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
EasyBCD
Assembly Version: 1.7.2.7
Win32 Version: 1.7.2.7
CodeBase: file:///C:/Program Files (x86)/NeoSmart Technologies/EasyBCD/EasyBCD.exe
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/Windows/assembly/GAC_MSI...0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/Windows/assembly/GAC_MSI....0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/Windows/assembly/GAC_MSI..._b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/Windows/assembly/GAC_MSI....0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3074 (QFE.050727-3000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
msfeeds
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/msfeeds/1.0.0.0__7df935e7b230192c/msfeeds.dll
----------------------------------------
************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.
For example:
<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>
When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Could someone fix this?
 
#2
Hello Techman224, welcome to NST.
Try using the [thread=642]beta of EasyBCD[/thread] instead. Many new features have been added by Build 60, and several bugs in the 1.7.2 version, and later versions too, have been fixed.
Please tell us if the problem still occurs using 2.0 Beta.

Jake
 
#3
Hello Techman224, welcome to NST.
Try using the [thread=642]beta of EasyBCD[/thread] instead. Many new features have been added by Build 60, and several bugs in the 1.7.2 version, and later versions too, have been fixed.
Please tell us if the problem still occurs using 2.0 Beta.

Jake
I've tried build 60, but even if I add a Wubi entry, it doesn't work because ubuntu is installed on another partition that also has windows, but isn't the boot partition. Would it be possible to add the option to select which partition Wubi is installed on? Maybe that could be added in build 61. Thanks.
 
#4
I've tried build 60, but even if I add a Wubi entry, it doesn't work because ubuntu is installed on another partition that also has windows, but isn't the boot partition. Would it be possible to add the option to select which partition Wubi is installed on? Maybe that could be added in build 61. Thanks.
Build 60 already has that feature. Go to the Change Settings section of EasyBCD, select your Wubi entry under "Choose an OS to change the associated settings", and then use the Drive drop-down menu to select the partition Wubi is installed to, and then it should work.

Cheers.

Jake