Used Vista EasyRE now won't boot to anything but the repair dashboard

#1
I have Windows Vista Home Premium on a HP Pavilion Desktop. I had been having problems for the last several months with errors for missing or corrupted files, however my computer would boot and I could do most stuff. I figured it was time to fix it and read a review that pointed me to the neosmart recovery/repair disk. I purchased and burned both iso files to disks.

I ran EasyRE and let it do it's thing. It came back and said it was done and I removed the disk and restarted. My computer booted into the blue recovery screen, if left to itself it then goes on to boot into the recovery dashboard. When running the repair tool again it says that the OS booted fine.

I tried system restore, but the tool does not see any of my system restore points.

Placing the disk in and restarting, the browser does not connect, nor does the backup util see any files except that which the EasyRE placed on my HD.

I tried to force safe mode to start from the command prompt using bcdedit {default} safebootminimal. It did nothing.

I tried most everything else except a complete reinstall.
When I chose the recovery complete it popped me into the HP recovery manager from which I am now backing up my files just in case.

Any help would be appreciated.:x