Windows 10 - 0xc0000428 Boot error

#1
(says cannot verify signature on \windows\system32\winload.efi but that cant be true, valid windows file and signed..)
Hi
Using MDT, we placed a windows 10 image on the 2nd ssd drive.
I used easibcd 2.3 to add the boot to the win 10 e: drive. As you can see this has an EFI boot partition for Windows 7.
It did not work.
I tried all the options I could think of, including making Disk 0 the master, no joy.
NB: Disk 1 was the original boot drive.

>> Any hints how to solve this and why EasiBCD just didn't work ?
(I would have thought that the D: here would have been ignored when E: was added as the 2nd OS...)

Thanks

P50_boot.png
 
#2
Forum does not allow edits so will add here . I found EasyBCD and UEFI but still am unclear the way forward.
I make this point, Neosmart know the rules, and EASiBcd knows these as well. It gave me a warning and went ahead and added the Windows 10 entry.
You have an expectation that other that twilight zone issues, the tool covers most cases.

Surely if it knows this cannot work, it should tell the user it cant be done and possibly reference a help URL ?
 

mqudsi

Mostly Harmless
Staff member
#3
This is likely not related to EFI - it's probably caused by an outdated BOOTMGR.EFI
If you have a BOOTMGR or BOOTMGR.EFI from an older version of Windows and try to load one from a newer, you'll get the same (misleading) error message about signature verification failure.

In your case, it's almost certainly caused by the attempt to load Windows 10 with the Windows 7 bootloader. You'll need to replace bootmgr and bootmgr.exe (also renamed to bootx64.efi) on the EFI boot partition with the files from the Windows 10 DVD or from C:\Windows\boot\ from the Windows 10 drive. EasyRE can automate this process for you.
 
#4
Thanks for the info
I find I can't assign a drive letter to the EFI partition so I don't seem to be able to do this.

Also note that nothing I did in EasiBCD would allow me to change the default boot partition to the Disk 0 drive which I assume resolve the issue because EFI would no longer be in use.

Also note that boot to USB sticks also affected somehow by this, i.e. woul dhave thought the MBR would be ignored when USB key selected.. BIOS set to BOTH with legacy first. (typically \boot\bcd 0xc0000225)
Also Windows menu does not respond to F8 even though it says it is an option

Will try EASYRE..
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#5
You can assign a letter to the EFI partition via the command line:

Code:
mountvol S: /S
It's just a FAT32 partition, but Microsoft likes to treat it super-special :smile:
 
#6
mqudsi - Thanks but you reply does not help me to make the Disk 0 the boot device. i.e. Legacy booth to it then add the windows 7 to the running win 10.
Also from previous post - Windows 7 did have August 2015 files, replaced with Windows 10 files, made no difference to issue.

This is on a new Lenovo P50, I spent the US$40 on EasyRE as there is no trial,
I tried all 3 modes it offered and none of them would even get to the screen.
EASYRE
>> Can someone please confirm this image does contain the heart of EasiBCD and is not just another winpe - Linux boot disc ?
On a HP laptop (old) I saw Recovery, file explorer, and partition editor (use of this just restarted the laptop)
I saw no boot record gui option in EasiRE.

NB: I also have 10x EasyBCD licenses , not seeing the Easy part at the moment.

IMG_20160222_160602.jpg
 
Last edited: