Windows 7

#1
I had a triple boot ( Vista, XP and Ubuntu) on 3 physcial hard drives. All worked well, then the XP drive went bad. I transfered my Windows 7 drive (full version, Professional) from my stand alone test computer to my personal computer and made the proper entries and ran auto config on EasayBCD 2.0 Build 2.0.0.76.

Vista and Ubuntu still boot OK but Windows 7 brings up a black screen saying "a recent hardware or software change might have installed a file that is signed incorrectly or damaged or might have malicious software from an unkown source." it goes on to say about F8 options use install disk or to " temporary disable driver signature enforcement". You can't use F8 and when you hit enter it just recycles the black screen.

Any Ideas?
Disk (0) New Volume C: (windows 7)
Disk (1) (Ubuntu)
Disk (2) L: (Vista)

Thanks
JeffTech
PS: EasyBCD is installed on L: drive Vista
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Hi Jeff, welcome to NST.
Vista quite often seems to think that W7 Winload.exe has an invalid digital signature.
The workaround is to put W7 1st in the BIOS boot sequence and use EasyBCD 2.0 to add entries for the other systems to the W7 BCD.
 

mqudsi

Mostly Harmless
Staff member
#3
Terry, the new EasyBCD has a feature to fix this, forgot to mention it:

EasyBCD | Diagnostics | Recreate Files
 

Terry60

Knows where his towel is.
Staff member
#4
OK. I'll try to remember for next time.
(thought for EasyBCD 3.0 - GUI just a single screen - one large button )

Heal Me !

(Fixes all known problems)
 
#5
First of all Thanks! 2 out of three operating systems isn't bad. I did as instructed and changed boot priority and then installed EasyBCD 2.0.0.76 I added Vista and NeoSmart Linux. I didn't check the box to install Grub loader?

When I boot now the screen shows Windows 7 then Vista then Neo Smart Linus. Windows 7 and Vista boot up but when I select NeoSmart Linux all I get is a black screen with a blinking cursor top right. Also when you look in settings it shows Entry 3 as NeoSmart linux Drive C:\ Bootloader path: \NST\nst_linux.mbr. Shouldn't is show as Disk (0) ?
Thanks
JeffTech
 
#6
Hi Jeff, welcome to NST.
Vista quite often seems to think that W7 Winload.exe has an invalid digital signature.
The workaround is to put W7 1st in the BIOS boot sequence and use EasyBCD 2.0 to add entries for the other systems to the W7 BCD.
According to him, Terry, Disk 0 is Win 7...

Addendum:

First of all Thanks! 2 out of three operating systems isn't bad. I did as instructed and changed boot priority and then installed EasyBCD 2.0.0.76 I added Vista and NeoSmart Linux. I didn't check the box to install Grub loader?

When I boot now the screen shows Windows 7 then Vista then Neo Smart Linus. Windows 7 and Vista boot up but when I select NeoSmart Linux all I get is a black screen with a blinking cursor top right. Also when you look in settings it shows Entry 3 as NeoSmart linux Drive C:\ Bootloader path: \NST\nst_linux.mbr. Shouldn't is show as Disk (0) ?
Thanks
JeffTech
Didn't notice your post until just now...
No, the C: part just means that this is where the chainloader for Grub is located. Its on the Windows "system" partition, which contains all the boot files of the Microsoft OSes (with the exception of winload.exe, which is stored on the OS's own partition...).
Which Ubuntu is this?
If its 9.10, which uses Grub2, you'll need to use the Grub2 option in EasybCD.
Otherwise, just delete the Linux entry in EasyBCD, and add it again, remembering to select the correct partition Ubuntu is installed to under "Devices:".
 
Last edited:
#8
In Add/Remove Entries, select the Linux tab, select the Type menu, and pick "Grub2".
(Sorry for the multiple posts...problem with my internet connection; i'll remove the extra ones in a sec)
 
#9
We are getting close just not there yet. I did as instructed and when I enter Neosmart Linux from the boot screen I get a black screen showing Grub 4DOS 0.4.4 2009-06-20......... {minimal BASH-like line edeting is supported......} and then Grub> with a flashing cursor. I typed in "boot" and it replied that the kernel wasn't loaded.

Sorry to be so dumb about this. You all are great for helping like this.

JeffTech

By the way it is Ubuntu 9.10

Addendum:

I can change the boot prority in the BIOS and Ubuntu will boot fine. It just will not boot from EasyBCD.

Thanks
 
Last edited:
#10
Addendum:

I can change the boot prority in the BIOS and Ubuntu will boot fine. It just will not boot from EasyBCD.

Thanks
Hmm...don't know why the Grub2 option in EasyBCD isn't working. I don't know a whole lot about Grub 2.
Do you get the Grub menu when you change the BIOS boot sequence, and is there an entry in there for W7?
If so, then you could at least dual-boot that way at until CG arrives in this thread again, and tells us both why the Grub2 option is failing. :wink:

EDIT: At the Grub prompt, type:
Code:
kernel /boot/grub/core.img
boot
It just might boot...
 
Last edited:
#11
When I change the BIOS Boot order Ubuntu boots right up no EasyBCD screen, just the standard black screen for Unbunt booting it shows loading the kernel ect. ect.. The entries on the EasyBCD screen are Windows7(1st) Vista (2nd) and then Neosmart Linux (3rd). I'll try your suggestion in a few mins. after the coffee kicks in.

Thanks

JeffTech

Addendum:

I tried you command and it did nothing except replied invalid prompt. If you hit the tab key it will list a bunch of commands. I tried a few like background, Boot, Cat, and unhide which came back with"partition (hd0,0) was already unhidden. I tried several more but it was over my head. However when you type "reboot" it will do just that, it reboots back to EasyBCD. I also went back to EasyBCD and tried Auto config and it's still the same.

Thanks
JeffTec
 
Last edited:
#12
Sorry.
I believe you'll need to do

root (hdx,y)

first, where the "x" is the HDD of your Linux install (beginning the count starting at 0), and the "y" is the partition (beginning the count also at 0). Then type the above commands again.
 
Last edited:
#13
I tried "root (hdh0,0) kernel /boot/grub/core.img boot" and it replied Error23: Error while parsing number. When I start Neolinux there are 2 screeens that flash very quickly before the last screen and they flash so quickly that I can't pause them. One looks like it saying "Turning and the other looks like it's saying start" but I'm not sure.

Since Ubuntu will boot from a BIOS prority change, is it possible the problem is in Grub 2.0?

Thanks

JeffTech

Addendum:

I've discovered what screen is showing when I select Neosmart linux on the EasyBCD screen. It's Ubuntu's Command line interface. Some of what I've read states that: "your computer should automatically boot into menu mode if you have grub installed, but only when there is a /boot/grub/grub.cfg file present. If there is no /boot/grub/grub.cfg file present your computer will boot into CLI mode."

So is the /boot/grub/grub.cfg part of EasyBCD? I still don't understand why it will boot when I change my BIOS prority and it boots straight into Ubuntu without a menu mode?

Thanks
JeffTech
 
Last edited:
#14
I tried "root (hdh0,0) kernel /boot/grub/core.img boot" and it replied Error23: Error while parsing number.
That's wrong. There shouldn't be a second "h" in there. Its just

root (hd0,0)

,meaning the first HDD in the boot sequence of the BIOS, and the first partition of that HDD. Most probably, that isn't the real location of your Linux partition anyway. You can use "sudo fdisk -l" (the last letter is a lowercase L) to find the correct numbers, in sdxy notation, though you'll have to convert to hdxy syntax (i.e. sda1 = hd0,0).

When I start Neolinux there are 2 screeens that flash very quickly before the last screen and they flash so quickly that I can't pause them. One looks like it saying "Turning and the other looks like it's saying start" but I'm not sure.

Since Ubuntu will boot from a BIOS prority change, is it possible the problem is in Grub 2.0?

Thanks

JeffTech
Its likely the problem is its not finding the kernel for some reason, when you attempt to via NeoGrub (through the NST menu.lst). Have no idea why that is.
Addendum:

I've discovered what screen is showing when I select Neosmart linux on the EasyBCD screen. It's Ubuntu's Command line interface. Some of what I've read states that: "your computer should automatically boot into menu mode if you have grub installed, but only when there is a /boot/grub/grub.cfg file present. If there is no /boot/grub/grub.cfg file present your computer will boot into CLI mode."

So is the /boot/grub/grub.cfg part of EasyBCD? I still don't understand why it will boot when I change my BIOS prority and it boots straight into Ubuntu without a menu mode?

Thanks
JeffTech
No. First of all EasyBCD is NOT a bootloader, however it does install a bootloader (NeoGrub) which attaches itself to the Windows bootloader, when adding a Linux entry. grub.cfg is the configuration file for Grub2. It should be located on your Linux partition.
 
#15
Since I don't understand (a)EasyBCD completely, and (b) the new Grub 2.0, if I reinstall Ubuntu 9.10 on my third drive will the new Grub 2.0 wipe out my Windows 7 and Vista or will it rewrite everything and I'll be OK? I need to move on here I have a project I need to start in linux and it's a pain to change the BIOS everytime I want to use Ubuntu.

Thanks
JeffTech
 

Terry60

Knows where his towel is.
Staff member
#16
Install Ubuntu making sure at the bootloader setup stage that you click the "advanced" button.
This brings up another screen, in which you tell it to install Grub to the Linux partition, not to the MBR.
This will leave your current boot process untouched.
Then boot W7, run EasyBCD 2.0, add/remove entries, Linux tab, "type" Grub2.
No more information is needed (that's why it all greys-out)
You should then have a working triple boot.
 
#17
OK, I will do that. Thank you all , for all of your help.

Thanks
Jefftech

Addendum:

OK GREAT! I'm now replying from Ubuntu as my triple boot is working. I guess I've never noticed the advanced tab in installing before.

Thank you all.
JeffTech
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#18
You're not the only one Jeff. It's the most common problem we see after a Linux install.
(I'm the type of person who always clicks on the advanced or custom buttons during any install. Sometimes that's the only place to direct a Windows app to where you want it (not C: ) )
It seems to be a common feature of all Linux installs, which will default to taking control of the boot unless specifically stopped.