Results 1 to 10 of 10

Thread: Booting PC-BSD entry->PXE resulted in serious trouble...

  1. #1
    Join Date
    Dec 2008
    Location
    Nowhere
    Posts
    2,903

    Exclamation Booting PC-BSD entry->PXE resulted in serious trouble...

    Ok, I mentioned in another thread that I had PC-BSD installed on an external USB hard drive, and was wanting to boot it with the W7 boot manager, by adding an entry for it in EasyBCD, but Windows wasn't reading the disk correctly. Well, long story short, I got Windows to read the disk correctly (by using Testdisk to create a GPT style partition table) now, and so I was able to add a PC-BSD entry to the W7 boot menu with EasyBCD, pointing it at the 3rd partition (approx. 20 GBs in size) on the disk, which I know contains PC-BSD, though there seems to be an issue with EasyBCD not detecting the filesystem right. But anyway, I went ahead and rebooted (with the USB HD still connected, and mounted), then selected the PC-BSD entry in the boot menu, and pressed Enter. But now, it gave me like 3 options. One of them was Boot, which I clicked right away, which just brought me back to W7's boot menu, I don't remember what the first one was, but I next clicked the second option called "PXE". BIG MISTAKE!! That brought me to a screen saying no boot device, and to insert boot disk and press enter. Since I didn't want to do that, I pressed Ctrl + Alt + Delete to restart, thinking that would bring me back to W7's boot menu...but nope, I was wrong. It doesn't. Each time I restart, and each time I turn off and turn back on my computer, it comes back to that same PXE screen, asking me for a boot disk, and there's no way to get past it except by inserting a boot disk, so I inserted my BootIt NG disk, entered Partition Work, and now all of my partitions are missing on my main drive!! I only see free space on my hard drive. But I'm thinking (and hoping, of course...) that its probably just not loading the hard drive because its getting interrupted by that PXE screen. But just in case the PXE thing screwed up my disk's MBR or something, I went ahead and inserted the W7 installation disk, booted from it, and tried Startup Repair. It doesn't even see my OS. It says "Unknown OS on Unknown", but I went ahead and ran it anyway (once), and so it completed doing its thing, and asked me to restart. But when I did that, once more loaded into Windows Recovery Environment (this time doing "bootrec /fixmbr" from Command Prompt) and tried booting from the hard disk, I still get the PXE screen, so obviously it didn't fix anything.
    So..I decided, it might be a good idea to find out what PXE is, so I googled it, and learned it is a Preboot Execution Environment which is an environment to "boot computers using a network interface independently of data storage devices (like hard disks) or installed operating systems".
    So now that I know what it is, I'm wondering how to disable it, and get back to my normal boot from my hard disk, now that I accidentally started it up from PC-BSD's boot manager...

    Any ideas??

    Thanks in advance.
    Last edited by Coolname007; May 5th, 2012 at 10:46 PM.

    The DARK knight. The knight of DARKNESS.
    SHADOW
    killer. The NINJA, master of darkness, stealth and invisibility.
    Jake Johnson

    Having dual-booting problems? Have a read of the following links to help you better accomplish your goal:

    1. PLEASE READ BEFORE POSTING WITH A PROBLEM | 2. Steps for Multibooting | 3. Multibooters - Understanding the Multiboot Process

  2. #2
    Join Date
    Apr 2006
    Location
    Chicago
    Posts
    13,323

     

    The problem isn't with PXE. PXE just means "boot from network" and has nothing to do with your issue - your really issue is the GUID partition table which would break a Windows installation done via MBR. When you converted the partition to GUID via testdisk and then rebooted, you lost any ability to use anything other than PC-BSD, being the only GUID-capable installation you had on your disk.

    What you need to do is boot into PC-BSD or a Linux live CD and use testdisk to search for and recover MBR partitions. You *may* have broken it permenantly by trying to force bootrec, I do not know.
    Mahmoud Al-Qudsi, Director



    I'm sorry but I do not accept support requests via IM, email, or personal messages

    Follow us on twitter @neosmart or on Facebook!
    Like us on facebook!

  3. #3
    Join Date
    Dec 2008
    Location
    Nowhere
    Posts
    2,903

     

    Quote Originally Posted by Computer Guru View Post
    The problem isn't with PXE. PXE just means "boot from network" and has nothing to do with your issue - your really issue is the GUID partition table which would break a Windows installation done via MBR. When you converted the partition to GUID via testdisk and then rebooted, you lost any ability to use anything other than PC-BSD, being the only GUID-capable installation you had on your disk.

    What you need to do is boot into PC-BSD or a Linux live CD and use testdisk to search for and recover MBR partitions. You *may* have broken it permenantly by trying to force bootrec, I do not know.
    But I can't boot into PC-BSD anymore. Not from Windows 7 boot manager on my new computer, or from BootIt NG on my old computer, since BootIt NG only sees the Protective MBR partition spanning the entire disk. Also, I don't see how converting my external hard drive to GUID partition type with Testdisk could mess up my main hard drive running Windows 7 and Ubuntu. I didn't touch my main hard drive with Testdisk...I only operated on sdb, which is my external hard drive containing PC-BSD.

    The DARK knight. The knight of DARKNESS.
    SHADOW
    killer. The NINJA, master of darkness, stealth and invisibility.
    Jake Johnson

    Having dual-booting problems? Have a read of the following links to help you better accomplish your goal:

    1. PLEASE READ BEFORE POSTING WITH A PROBLEM | 2. Steps for Multibooting | 3. Multibooters - Understanding the Multiboot Process

  4. #4
    Join Date
    Dec 2008
    Location
    Nowhere
    Posts
    2,903

     

    Quote Originally Posted by Computer Guru View Post
    When you converted the partition to GUID via testdisk and then rebooted, you lost any ability to use anything other than PC-BSD, being the only GUID-capable installation you had on your disk.

    What you need to do is boot into PC-BSD or a Linux live CD and use testdisk to search for and recover MBR partitions. You *may* have broken it permenantly by trying to force bootrec, I do not know.
    I'm sorry, but all the evidence points contrary to that statement:

    1. I only used Testdisk on my external hard drive, not my main internal hard drive which contains W7 and Ubuntu.
    2. Even if Testdisk, by some weird occurance, had somehow messed up my main hard drive, the first reboot
    would not have brought me to the W7 boot menu with entries "Windows 7 Ultimate", "Ubuntu 11.10", and "PC-BSD",
    since it would not be able to access the "system" partition (which is my Recovery partition, the second partition on
    my main hard disk), and chainload bootmgr with the boot sector code, and probably wouldn't have been able to
    even access the hard drive at all. Yet, the first reboot DID bring me to my W7 boot menu, and only after selecting
    PC-BSD, and then "PXE", did my boot get screwed up.
    3. I took the last part of your advice as far as booting from my Ubuntu LiveCD, and running Testdisk is concerned,
    though I have not done any recovery operations yet, since Testdisk shows the following (see attachments):
    Attached Images Attached Images
    Last edited by Coolname007; May 6th, 2012 at 10:34 AM.

    The DARK knight. The knight of DARKNESS.
    SHADOW
    killer. The NINJA, master of darkness, stealth and invisibility.
    Jake Johnson

    Having dual-booting problems? Have a read of the following links to help you better accomplish your goal:

    1. PLEASE READ BEFORE POSTING WITH A PROBLEM | 2. Steps for Multibooting | 3. Multibooters - Understanding the Multiboot Process

  5. #5
    Join Date
    Apr 2006
    Location
    Chicago
    Posts
    13,323

     

    Your HD seems fine (thankfully).

    Silly suggestion, but perhaps the boot device order has been reset in the BIOS?
    Mahmoud Al-Qudsi, Director



    I'm sorry but I do not accept support requests via IM, email, or personal messages

    Follow us on twitter @neosmart or on Facebook!
    Like us on facebook!

  6. #6
    Join Date
    Dec 2008
    Location
    Nowhere
    Posts
    2,903

     

    Quote Originally Posted by Computer Guru View Post
    Your HD seems fine (thankfully).

    Silly suggestion, but perhaps the boot device order has been reset in the BIOS?
    That's one of the first things I checked, but my CD ROM drive was first, followed by the Hard drive, and then by the Network device, but the PXE boot screen still showed every single time.
    I even put Hard drive first, but still the same thing...
    I tried disabling the Network thing option in the BIOS, which made the Network option disappear from the boot devices menu, and then I tried booting, but that just showed me the last
    message normally displayed on the PXE boot screen (minus the PXE stuff):

    No boot device; please insert boot disk and press Enter
    Its like the PXE boot environment has been initialized, and is preventing any attempts of the BIOS to load the hard drive, and its just failing.
    On top of that, it doesn't give me any option of disabling it or bypassing it in any way. I've tried pressing Esc, all of the F* keys, Ctrl + S (which
    other people with the same problem have reported bringing up a PXE menu, but no such menu shows up in my case), Ctrl + A, etc...still nothing.
    There is no option in my BIOS which seems to disable its full effects either.
    So I did follow your suggestion, and used Testdisk from the Ubuntu liveCD to locate the partitions on the main hard drive, and write the partition
    structure to disk, which fixed it partly (I was now getting the W7 boot menu, but when I tried to load W7, it failed, and told me to run Startup Repair,
    and so I did, and this time, Startup Repair fixed it, since I guess it was an issue with the partition device in the BCD entry being wrong for some reason).
    So once I got into W7, I went ahead, and removed the PC-BSD entry completely, since that is what messed up my boot originally, and then I wanted
    to check and see if Ubuntu still loaded fine, so I rebooted, selected Ubuntu's entry, and now I noticed something weird going on with that! Now
    the Ubuntu entry is showing a similiar "Boot", "PXE", etc. option screen, and is failing to load Ubuntu. The way to select any of the options on that
    screen is by using a F* key for each one, such as F1, and F5. But now, pressing any of those keys (even if its "Boot") puts my computer right back
    into that same PXE boot crap. So I ended up having to use Testdisk all over again, and so now I'm typing this in W7 on my second run. So I've decided
    to forget about using the Windows boot manager to multiboot anymore, at all, and instead just install Grub to the MBR. I'm not sure what the deal
    is with the whole "PXE" crap, but the behavior is now becoming pretty consistent on my machine, so I'm opting out of using the W7 boot manager to
    control the boot anymore. Screw that. I want to say though that I've tried all Linux type of entries in EasyBCD (i.e. "Grub2", Grub (Legacy) with Ubuntu partition selected, and Grub (Legacy) with "EasyBCD's copy of Grub" selected), but they all fail
    to work with Ubuntu anymore too. Grub2 and Grub (Legacy) with "EasyBCD's copy of Grub" option checked both bring up a similiar PXE boot screen, while Grub (Legacy) just shows a blinking cursor. Grub2 is the type in EasyBCD I was using before, and it worked, but not anymore. That's why I say I'm done using the W7 boot manager to control my multiboot anymore on this machine at least.
    Last edited by Coolname007; May 6th, 2012 at 11:55 PM.

    The DARK knight. The knight of DARKNESS.
    SHADOW
    killer. The NINJA, master of darkness, stealth and invisibility.
    Jake Johnson

    Having dual-booting problems? Have a read of the following links to help you better accomplish your goal:

    1. PLEASE READ BEFORE POSTING WITH A PROBLEM | 2. Steps for Multibooting | 3. Multibooters - Understanding the Multiboot Process

  7. #7
    Join Date
    Apr 2006
    Location
    Chicago
    Posts
    13,323

     

    No, you're misunderstanding the priority I was referring to.

    Other than the device type priority, there's the HD priority.
    Make sure your Windows drive is the first within the HD segment (instead of the PC-BSD drive)
    Mahmoud Al-Qudsi, Director



    I'm sorry but I do not accept support requests via IM, email, or personal messages

    Follow us on twitter @neosmart or on Facebook!
    Like us on facebook!

  8. #8
    Join Date
    Dec 2008
    Location
    Nowhere
    Posts
    2,903

     

    Quote Originally Posted by Computer Guru View Post
    No, you're misunderstanding the priority I was referring to.

    Other than the device type priority, there's the HD priority.
    Make sure your Windows drive is the first within the HD segment (instead of the PC-BSD drive)
    In my BIOS, there is only the device type priority, which has both a "Hard Drive" device and a "USB Bootable Drive" or some such device.
    When I'm in RAID mode, there is only one hard drive device seen by the BIOS, since both internal hard drives in my laptop are part of the single RAID volume.
    But when I'm in ATA mode, it shows the second hard drive in the device type priority too. But that is only when I'm in ATA mode.

    Addendum:

    Whoo...I'm back in Ubuntu.
    I installed Grub to the MBR from the LiveCD, rebooted, saw the Grub2 boot menu at startup, selected the first option, and the Ubuntu logo loading screen showed up, but then reported an error "Serious disk errors on drive searching for /" or something to that effect,
    and to press I to ignore, S to skip mounting, or M to manually recover. After a little playing around, I pressed M, then Enter, which brought to a root prompt, at which, I ran did a filesystem check on the Ubuntu partition, which found an error with the last mount time being in the future
    for some reason, and asked me if I wanted to fix it, I said yes, so it fixed it, tried booting again, still same error thing...so I pressed I this time to ignore which brought me into Ubuntu again. Next, I ran "sudo update-grub" again, since my Ubuntu partition is now dm-6, instead of dm-7
    for some reason (seems to have switched places with my Swap partition, at least as far as Ubuntu sees it), with Swap being dm-7 now. Also looked at my /etc/fstab file, and noticed that its still looking at /dev/mapper/isw_bgajfdadfj_M17xRAID0Volume7 as the Ubuntu ext4 partition,
    and /dev/mapper/isw_bgajfdadfj_M17xRAID0Volume6 as the Swap partition, so I switched that around in my fstab file, rebooted, selected the first option in Grub 2 boot menu again, and this time it loaded Ubuntu without me seeing that error. So it seems I fixed that issue too.
    I'm thinking those two issues might have also been the reason why the Ubuntu boot from the W7 boot menu didn't work so good anymore, so to test that theory, I'm going to try loading W7, and adding an entry for Ubuntu again to the BCD, and try selecting that to see if it works.

    I'll let you know how that goes.
    Last edited by Coolname007; May 7th, 2012 at 10:10 PM. Reason: Automagically-merged double-post.

    The DARK knight. The knight of DARKNESS.
    SHADOW
    killer. The NINJA, master of darkness, stealth and invisibility.
    Jake Johnson

    Having dual-booting problems? Have a read of the following links to help you better accomplish your goal:

    1. PLEASE READ BEFORE POSTING WITH A PROBLEM | 2. Steps for Multibooting | 3. Multibooters - Understanding the Multiboot Process

  9. #9
    Join Date
    Apr 2006
    Location
    Chicago
    Posts
    13,323

     

    Good luck...
    Mahmoud Al-Qudsi, Director



    I'm sorry but I do not accept support requests via IM, email, or personal messages

    Follow us on twitter @neosmart or on Facebook!
    Like us on facebook!

  10. #10
    Join Date
    Dec 2008
    Location
    Nowhere
    Posts
    2,903

     

    Nope..no luck.
    Still the same PXE boot options screen when I selected Ubuntu's entry in the BCD.
    So I'm going to forget about booting Ubuntu that way, and leave Grub installed to the MBR.
    Right now, I'm able to boot into both W7 and Ubuntu through Grub just fine, so I have a dual-boot.

    The DARK knight. The knight of DARKNESS.
    SHADOW
    killer. The NINJA, master of darkness, stealth and invisibility.
    Jake Johnson

    Having dual-booting problems? Have a read of the following links to help you better accomplish your goal:

    1. PLEASE READ BEFORE POSTING WITH A PROBLEM | 2. Steps for Multibooting | 3. Multibooters - Understanding the Multiboot Process

Similar Threads

  1. creating entry for PC-BSD
    By luap52 in forum EasyBCD Support
    Replies: 6
    Last Post: May 2nd, 2012, 07:42 PM
  2. Win7, Ubuntu and PC-BSD?
    By Mak 2.0 in forum EasyBCD Support
    Replies: 9
    Last Post: February 28th, 2011, 09:23 PM
  3. newbie wants to triple boot - Win7, Dt-BSD, & PC-BSD
    By donnybb in forum EasyBCD Support
    Replies: 1
    Last Post: May 13th, 2009, 02:45 PM
  4. EasyBCD and support for PC-BSD?
    By Mak 2.0 in forum EasyBCD Support
    Replies: 0
    Last Post: March 12th, 2009, 06:13 PM
  5. Vista / PC-BSD 7 / EasyBCD
    By Braveheart_BSD in forum EasyBCD Support
    Replies: 15
    Last Post: October 25th, 2008, 09:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •