Changed Ubuntu to default OS and now can't boot vista


So I set up Ubuntu using Wubi, but I couldn't get it to give me it as an option in startup, so I downloaded EasyBCD aand in a fit of irritation changed the defualt OS to Ubuntu. Now Ubuntu loads fine but I get no option to load vista. I can't seem to get into the bios either tried pressing F2 and F12 at start up and it just hangs. Any ideas, I need to get access to the vista part of my PC pretty urgently!

PC is a dell Inspiron 531.

Any help greatly appreciated,

First EasyBCD wouldn't prevent you from getting into the bios since that option comes up before any boot loader or tool for Vista's own boot loader. You are likely seeing a weak battery on the board for a system used for a year or more a non serious problem.

If there's an F key assigned to bring up the boot device menu where you can select which drive to boot from simply have the Vista dvd in the drive when selected. Once past the initial load up and choice of region and language and proceeding onto the "Install Now" screen note the repair tools option seen below. That will bring up another screen with Vista's new automatic startup repair tool for seeing the boot information corrected.
The boot key PC Eye is referring to is F12. It seems to me as if it is a cmos battery problem too. The system shouldn't hang when accessing the BIOS unless it is busy detecting the hardware. If its doing this each time you boot the computer than this is the case because the settings are lost each time the cmos battery fails. When you do get into Ubuntu, does the system have the correct date/time in the notification area?
Last edited:
On some prebuilds it could be the F4 key instead of the F12 while those are the common subsitute for the Del key to enter the bios setup. If the battery is weak and you are able to get into the boot menu you may still have some problems getting to the repair tools section while waiting for the initial loadup. Grub apparently saw something lost as well to no longer see the "C:\Windows" option.
Thanks for the replies, I've tried every function key now in an attempt to get into the bios but none work. What happens is the PC starts to power up I press a function key and the it just stops, sounds like it's gone into sleep mode. I don't get any options come on the screen to enter the bios if I just let it load normally. I've got the vista disk so I just need to get the PC to boot off it.

Is there anyway I could modify the boot order from within Ubuntu? Say with a similar program EasyBCD that let me do it in Windows.



When you do get into Ubuntu, does the system have the correct date/time in the notification area?

Yes it does.


Have now managed to make things worse. I tried to edit the boot order so opened up /boot/grub/menu.lst and swapped round windows and ubuntu hoping that this would boot windows first. Now it just hangs when I turn the computer on. As in it starts to power up and then nothing happens, at all. Doh!

Any ideas?
Last edited:
The "delete" key enters the BIOS on my ASUS mobo, and "tab" gives verbose mode.
Try some keys other than the PFs.
all good now no idea what the problem was. I unplugged everything left it for the day then wired it back up and turned it on, the bios menu popped straight up, booted into windows and all is good.

Thanks for the help.
Sounds like a flaky drive cable if anything. I've seen enough times with flat ribbon ide and even sata data cables where you had to fight just to boot with the Windows disk boot. Shut everything down suddenly all's well. Once the problem cable was replaced 100% Dependibility!