Linux options all fail


I've just bought an HP desktop with UEFI booting Win7, shrunk the "OS" partition to get 228 GB of free space, and installed Xubuntu 12.04.1 following instructions from How to dual-boot Ubuntu 12.04 and Windows 7 including use of EasyBCD to modify the Windows boot manager. Initially, EasyBCD failed to display the boot entries, but by following another thread here I tried the 2.2 beta build 180 and managed to access the BCD data.

However, when I reboot the machine and choose my Linux entry, I immediately get an error message that the AutoNeoGrub file is corrupt and cannot load.

The original instructions I used to install the Xubuntu package had me create a separate partition, sda5, for the /boot directory, and change the bootloader location from the MBR of sda to sda5. I've tried every EasyBCD option that I can think of, and now have three *.mbr files in the C:/NST folder of the Win7 drive -- but all of them return a 0xC000098 error when I attempt to boot through them. My question is "How do I force a valid file to use here?" I did find a GRUB2 option that let me specify the 500-MB /boot partition, on the final "add entry" attempt, but it gives the same result as the others.

Since I've not been able to get into the Xubuntu installation yet, I'd have no problem wiping it and re-installing from the Live CD. I'm no newcomer to Xubuntu, having used it for the past 5 years (coming originally from Slackware by way of Mandrake before arriving at Xubuntu). However I think I need some expert help getting the BCD package properly configured!

I do note that EasyBCD seems extremely slow (everything in Win7 seems slow, but EasyBCD is slower than most) and often goes into "not responding" state after I attempt any action with it. I also find a number of items listed on the menu that I never added, all with "Device=unknown" attributes. Could these be associated with my problems?
Last edited:


Mostly Harmless
Staff member
EasyBCD is not yet UEFI ready, and you'll have the same problem with most Linux distros, unfortunately.

There's one known issue that causes EasyBCD to go into "not responding" often - do you by any chance have the MS intellipoint mouse software installed? Certain versions have a bug that cause .NET apps to freeze.


I'm sorry to hear that EasyBCD isn't yet UEFI ready; it seems to be a great utility, but the only machine that I have with BCD is this one with UEFI!

The mouse I am using is a Logitech wireless unit. However I don't know what HP may have put into the driver collection. As always, the machine is loaded with bloatware, almost all of which I plan to purge ASAP. I may have to just reformat the drive and install Xubuntu as the only system on it!

Many thanks for your prompt response; while it's disappointing, it does save me from going any farther down a dead-end pathway.