7Zip not showing up on right click context menu windows 10 pro


Active Member
I've been using 7Zip for years Had no problems until recently when suddenly 7Zip no longer appears on the right click context menu! I'm using Windows 10 Pro version 21h2 and update windows regularly. That's on my main Lenovo desktop computer.

However, my Dell backup laptop with 7Zip still has 7Zip listed on the right click context menu! I've tried all the fixes I've seen online but none have worked!

I checked and on 7Zip file manager, under tools-options - Integrate 7Zip to shell context menu is checked. Don't like fooling with the registry but if the fix is there I'll give it a try. I do have the latest version of 7Zip too! I've uninstalled and reinstalled it too!dell w7zip.JPG
It appears OK on mine in Windows10 Pro x64 v.21H2.
I would uninstall 7-Zip then reinstall. That should fix it
These are the 7Zip entries in my registry that I know about. Not sure if there are more. Still can't get 7Zip to show up in the right click context menu even though it should show up! I've tried everything but nothing seems to work. I've tried every step I found online from 7Zip's website and other sites that supposedly fixed the problem but none of them work!
7zip context menu handler registry.JPG


    43.2 KB · Views: 5
    63.5 KB · Views: 8
    32.9 KB · Views: 5
    34.6 KB · Views: 4
This is what Google says:
Step 1: Open 7-Zip File Manager by typing 7-Zip in Start menu or Start screen and then pressing Enter key. Step 2: Next, navigate to Tools menu and then click Options to open Options dialog. Step 3: Here, under the 7-Zip tab, make sure that Integrate 7-Zip to shell context menu option is selected.
Been there done that. Like I've said I've tried every fix I came across including that one. Still doesn't show up and I have no idea why not.
When shutting down at night or whenever you choose, are you switching the machine completely off? Sometimes that is what;s required to get things working.
Unfotunately, after some updates relating to security, I too experienced this issue. However, I never experienced the issue when using both 32 and 64 bit versions together. However, after unistalling the 32bit, the problem showed up for the first time. The menu would display but nothing would work. I uninstalled and deleted all of it from my registry (all that I could find). When I installed the 64bit application, the problem was gone. At the time I was using Windows 10 Home, I upgraded to pro workstation and it was still flawless. I uninstalled, then installed some other apps, then reinstalled. It worked fine. I have updated those apps, I have reinstalled 7zip, and still found no solution to the problem. I had to update all my apps due to windows updates that broke functionality. I would suspect (due to seeing the option appear in the tools menu) that they are using a component that is still tied to a 32bit handler. Windows has been pushing this kind of programming out, due to exploits in the 32 bit architecture that are rife with virus attacks. They are also trying to keep from overflowing a 32bit memory space, which is limited to 4gb normally, but can extend, with special programming, to 6gb. Bottom line, your system may no longer support the handler being used. Try installing the 32bit version and see if it will work. I will and I will get back to you with results.

Found a problem with the UAC first run! That means there's a UAC access issue. Go to Program files where you installed, make sure the 3 EXE files are not set to run as administrator.
I've had this issue with other software as well, where drag and drop from explorer to the app won't work if the app is run as admin. It has something to do with protected memory access which doesn't always get carried over in subroutines or sub-apps.
Nice find, @Hal_85. A lot of programs fail to carry out actions if running unprivileged but don't report any errors and continue on as if they succeeded. Shoddy programming!
I'm experiencing exactly the same problem as the thread author. This error occurred on updating to the latest, 64-bit only version. I have also performed all the usual hacks mentioned in this thread - except using just the 32-bit version. Will uninstall the 64-bit version again and install just the 32-bit version.
Uninstalling the 64-bit version & installing the 32-bit version has not made a difference. I have also - options - enabled the context menus. Note that I had to run 7-zip as Administrator else got a "not allowed " message

Unfortunately this has not resolved the issue. There is nothing on the 7-zip forum in this regard. I'm out of time to spend on this now. Will revert if I have success later.

Would prefer to stick with 7-zip as opposed to moving to an alternative. It's been a "No Drama" app to-date.
Ta @Ex_Brit :smile: Started There, then googled and best answers came from here. Ran out of time with experimentation so unfortunately nothing further to add from my side. 32-bit definitely didn't work so will return to 64-bit. Might have an older version to try but think an earlier post hit the nail on the head with a MS change as probably the culprit. In which case it would just be truly weird timing that it coincided with me upgrading 7-Zip itself :smile:
Hi please follow the steps you will find the solution.Open the 7-Zip file manager by clicking 7-Zip on the Start menu or Start screen, and then pressing the Enter key. Step 2: Next, go to the Tools menu and click Options to open the Options dialog box. Here, under the 7-Zip tab, make sure the Merge 7-Zip in shell context menu option is selected. If not, please select an option and click the Apply button. You can restart your PC or restart Windows Explorer to see 7-Zip in the context menu. Fix: 7-Zip option missing from Windows 10 context menu Last updated on May 7, 2020 by admin 14 comments Recommended: Last week I did a clean install of Windows 10 on one of my computers replacing the previously installed Windows 7 operating system with Windows 10. Installation took a little over 15 minutes but went well. Once Windows was up and running, I installed a few essential tools, including 7-Zip, VLC, and TeamViewer. Earlier today, I noticed that the 7-Zip option was missing from the menu. As you know, when installed correctly, the 7-Zip option appears when you right-click on a file or folder. fix 7-zip missing from context menu step1 At first I thought the 7-Zip installation failed or was corrupted. So I uninstalled and reinstalled one, but the result is the same. But to play around with 7-Zip a bit, I forcefully added the 7-Zip option to the context menu. If the 7-Zip option is missing from the context menu in Windows 7, Windows 8, or Windows 10, here's how to fix it quickly. Enter 7-zip in the Windows 10 context menu We recommend that you go through the first step before following the second and third steps. Method 1 of 3 Step 1: Open the 7-Zip file manager by clicking 7-Zip on the Start menu or Start screen and then pressing the Enter key. Step 2: Next, go to the Tools menu and click Options to open the Options dialog box. fix 7-zip missing from context menu step2 Step 3: Here, under the 7-Zip tab, make sure the context menu option Merge 7-Zip into a shell is selected. If not, please select an option and click the Apply button. You can restart your PC or restart Windows Explorer to see 7-Zip in the context menu. fix 7-zip is missing from the status menu step3 If so, the 7-Zip option does not appear after completing the instructions mentioned above, please follow theadvice in step 2.