'A disk read error has occurred' after loading W7

#1
Hi,
Maybe I'm trying to be too optimistic here, but I'm trying to breathe new W7 life into an old Dell. I've seen reports of people loading W7 onto machines with much lower specs than this, so I'm expecting that it should be possible.
Its a XPS T600: Pentium III, 600MHz, 768MB RAM, A11 BIOS
It's had various OSes in its life - W2000, Server 2003 & XP.
Problem is that when I try to load W7 by ANY method (see below), the first time the machine reboots it gives a 'A disk read error has occurred' immediately the BIOS goes for the HD.
I know the HDD is fine, but just to make sure I tried 2 others with the same result. I am suspecting some kind of incompatibility between the BIOS and the W7 MBR format?

I have tried:
Loading W7 from DVD, deleting all previous partitions
Loading W7 from DVD as above, but deleting the system allocated 100M partition before it continues
Loading XP, then installing W7 from within XP
Loading XP, then W7 on separate partition as dual boot.
ALL of these methods result in the 'A disk read error has occurred' error the first time the W7 installation process reboots.

So, using the last 'dual boot' method, I did an XP fixmbr. This restored the XPboot, but does not show the alternative W7 boot (as expected).
I then used easyBCD - it showed 2 boot entries - 'previous version' on C: and Windows 7 on D:.
I used the restore MBR feature and rebooted.
Bang! Immediately the 'A disk read error has occurred' returned! Arrgh.
I can again restore the XP boot with the XP fixmbr function and get back to using easyBCD.
Can anyone suggest what is going on here and how to fix it?
Maybe I should just admit defeat and stick with XP - but then that's just not the right spirit...
TIA,
Alistair
 
Last edited:
#3
Yep, tried all of that. The problem seems to be with the MBR, not the BCD.
As soon as a Vista/7 MBR format is written to the HD, then the BIOS(?) appears not to recognise it as a valid (executable?) MBR and throws the error.

Is this a known issue with older BIOSes? If so, then I'm guessing there is no real resolution unless a newer BIOS is available?

TIA, Alistair
 

Terry60

Knows where his towel is.
Staff member
#4
The Vista MBR/IPL is slightly bigger than XP, so, I imagine is W7. Possibly there's a bad block at the start of the disk which one extends into and the other doesn't.
You could try a chkdsk /r to remove any possible bad block(s) before you try writing the W7 MBR again.