A drive letter question...

#1
Greetings!

I have a question that concerns dual booting SUSE and Vista. Grub is installed to the boot partition (logical, sda7).

When adding linux entry it labels that as S:\ , this is definitely not right. S is my primary boot partition as sda1 , Vista is on sda2. I think EasyBCD can't quite understand my machine as the partition numbers which it suggests are not that right also. I was able to recognise the right partition only that i knew how large the capacity was.

Well I can see that the Beta is available, maybe I need that instead?

Thanks mates, any help would be appreciated.

Addendum:

Well I tested EasyBCD 2.0 and it managed to give much better results. Partition numbers were right this time. Although it still wanted to put the NST folder to my primary boot partition. I was not pleased with that actually because it kinda was recommended not to edit that partition.

Anyway it worked fine with the NST folder on S:\ and also on C:\(when copied) so no problem there. Just would be nice to change/choose that location during the entry-adding process not after it has already made the folder and .mbr file.

Just some thoughts. :wink:
Thanks for the great application!
 
Last edited:

JustinW

Super Moderator
Staff member
#2
Hello Tartaros, welcome to NST

This is normal. Its supposed to install the files on the primary boot. It installs special .mbr files in its nst directory there that the entries point to in order to chainload grub for linux.
 
#3
Yes, I was aware about the reason the .mbr was made but it just gave me a fright when it edited the primary boot by default. My thinkpad's lenovo care button (the blue one) functionality depends on that partition. I was hoping to get it on my Vista partition instead. Fortunatelly all went fine : )
 
#4
Yes, I was aware about the reason the .mbr was made but it just gave me a fright when it edited the primary boot by default. My thinkpad's lenovo care button (the blue one) functionality depends on that partition. I was hoping to get it on my Vista partition instead. Fortunatelly all went fine : )
Well, the reason why the NST boot files were installed to that partition is because it is "system" in Disk Management, meaning it also contains your Vista boot files. :wink: The OEM of your laptop can be blamed for setting that partition to "active" instead of the partition that Vista is installed to. If you were to change the "active" flag to some other partition (your Vista one for instance), then your computer would no longer boot, because Vista's boot files are on the other partition. Setting a partition to "active" simply means telling the computer boot process to look in that partition in the boot files needed to load the OS, so it also needs to have the .mbr on the "active" "system" partition as well, otherwise it would not be able to boot into Linux.

Jake
 
#5
Setting a partition to "active" simply means telling the computer boot process to look in that partition in the boot files needed to load the OS, so it also needs to have the .mbr on the "active" "system" partition as well, otherwise it would not be able to boot into Linux.
Thanks for the reply Jake.

I have indeed Vista's bootmbr on my primary boot and it needs to be active, but to me it seems that NST folder with the .mbr file doesn't need to be necessarily on partition that is labeled as "active" and "system". How else I could still boot to Linux when I changed the letter, copied NST folder to C, and deleted .mbr from the primary boot...
 
#6
Well, it would seem like to me if you had the bootloader (i.e. NeoGrub) on a partition other than "system", there would need to be some way to point back at that partition from Vista's BCD (since the default points at the same partition that contains the BCD, i.e. the "system" partition). But I suppose if you happened to uninstall and then reinstall NeoGrub after moving the NST directory over to C (a partition other than "system"), it explains why it works. :wink: The only other possible scenario that I can imagine that might make that work is if you modified the BCD entry in some way to point back at the non-system partition, though it seems like that would have had to be done manually...

Jake

EDIT: That's assuming of course you did not use the standard Linux option in EasyBCD, which doesn't use NeoGrub...
 
Last edited:

JustinW

Super Moderator
Staff member
#7
Its simple really. Move the nst folder where ever you like and change the entry's path. If you can't do it in EasyBCD (im not sure if you can) than bcdedit is your best friend:

bcdedit /set {xxx} path <new location>
 
#8
Yes indeed, path can be edited with EasyBCD by changing drive to whatever you want under the Entry-Based Settings and by clicking Save. Of course now the folder must be moved to that location instead, it works well.
 

JustinW

Super Moderator
Staff member
#9
Great, sorry it doesnt give you that option at creation time. Most people don't really notice or care as long as their dual-boot is working.