Added NeoSmart boot info, now windows bootloader missing.

#1
Ok, I'm running Windows 8.1, (GPT UEFI), I have been running Kubuntu 13.10 and Zorin 8 (1310 also) and then since it was a 250 gb HDD, I played around with some other distro's, and even started with a minimal install in an effort to build my own distro, just because I can, (when restarting I would press F12 and choose either the USB HDD or the Windows boot menu it's worked for over a year now). I decided to download and update to 14.10 on both programs, So I downloaded both, put the iso on a thumb/flash (whatever you want to call it) drive, and after re-partitioning the usb HDD in a way I have been wanting to for a long time, Installed Kubuntu on the usb HDD. Rebooted and there was no Linux installed. Let me backup just a moment, after backing up all information I thought I might need I installed EasyBCDEdit, because after all my trying new distro's, there was about 10 versions of Linux in the Windows boot menu, even though I was only using two or three. So using EBCDE, I removed all those. No problem there, but after trying to install the new version and it wasn't there, just to make sure I hadn't done something stupid in the settings of EBCDE, I opened it back up and looked, nothing out of place. So after three more failed installs, I opened EBCDE back up, and clicked on "Add NeoSmart boot information", or however that is worded. Another failed install, tried to reboot Windows to see what else I could do, and Windows "Can not be found". I got my Windows rescue disk I got from Dell, tried it, got the error "That is for the wrong version of Windows", but it's not the wrong version. So I restart, and click repair my pc, and try to use the disk to restore the start-up information, it says, "repair failed please use your rescue dvd to fix the start-up information". I was using the dvd, and it still failed. During this, I realize that when I tried to put the iso on the thumb drive, it was leaving the thumb drive empty except for virtualbox. I don't know if the settings for the thumb drive got changed, or what, but I tried three different programs to "burn" the iso, and all three said "Success", but the drive was still empty, but that's a problem for a different board. I need to know if there is a way to fix windows without re-installing. I tried a 'refresh", and I forget now exactly what it said, but there was some kind of error about something missing, I thiink it was the OS is missing, but I don't promise that's right. Does anyone have any ideas that might fix my problem? please tell me you do, I will not lose any documents, or pictures or the like, I have been physically syncing those folders with a pc on our network that we are using for a backup server, as well as using OneDrive to back them up, weekly. However, all three of the backup programs I was using (all came highly recommended from friends, and computer technicians I know) all were backing up empty folders, or when I try to restore they say "directory unreadable". So I will lose all my settings and such, which I don't want to do. If you need anymore information, just let me know, thanks.