Another Dual Boot Question Window xp to linux mint

#1
Hello, I am new to linux, but I like it better than windows so far. I had Linux Mint 7 up and running for about two weeks and it was great. Then I decided I needed/wanted to have windows also. I read about dual booting and thought this could work perfect for me. Here is what is going on now.
I have windows xp loaded on one hard drive. (hd1) this is an IDE drive on the master side of the cable with the master jumper in place on the drive.
I have Linux mint load on a second hard drive (hd2) this is an IDE drive on the slave side of the cable with the slave jumper in place on the drive.
I have a third hard drive with no operating system at all, this is a SATA drive. My computer makes this drive (hd0), with this drive disconnected the computer seems to work fine I can dual boot into both operating systems just fine and use which ever one I choose. As soon as I hook up the third hard drive the MBR gets screwed up and I cannot boot into either operating system. When I fix the MBR (FIXMBR) through the windows set up disk, I am able to get back to windows but linux will not boot up anymore.
I should probably add that I have two other hard drives on my system for various reasons, these hard drives have no operating system on them at all one is a SCSI and one is an IDE. Neither of these drives seemed to affect anything when I had the system working without the number 3 hard drive hooked up.

So then I tried to get everything up and running with windows and the third hard drive. I had everything hooked up and running fine through windows and then I re-installed linux on the second drive. The installation went fine, but in the end I could still only get into windows, every time I tried to boot the linux drive the system would lock up during boot, the last thing on the screen was "verifying DMI pool data" and nothing would happen. I then read a little and loaded "auto super grub disk" When I booted with this installed I would have to press f12 during boot to get to the hard drive I wanted to boot to and select the windows hard drive, it would go to another screen allowing me to boot windows or boot the super grub disk. When I would boot into the super grub disk, I would get very confused. I did not know what to change to fix the problem and I tried a few different things. All of a sudden I was able to boot into linux and that worked fine, so I thought OK boot into windows now, I tried it by letting the computer boot on its own with no f keys being hit. It locked up at "verifying DMI pool data" again. So I re-booted and pressed the f12 to get the the boot screen and selected the windows drive, that went to the grub loader taking me to the boot up screen for linux and allow me to select linux or windows I tried windows and it told me to remove other operating system disks and boot from a cd/dvd then it locked up. I could still boot into linux at that time. I then booted up on my windows disk and ran the fixmbr program again. Now I am back to booing windows but I cannot get into linux. I keep getting the message “verifying DMI pool data” and then it just stops and nothing happens. It will do this weather I press the f12 key or just let it boot on its own.

This is what is written in the Menu.1st for linux: ( I excluded the top half which is mostly comments)

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Linux Mint 7 Gloria, kernel 2.6.28-11-generic
root (hd2,0)
kernel /boot/vmlinuz-2.6.28-11-generic root=/dev/sdc1 ro quiet splash
initrd /boot/initrd.img-2.6.28-11-generic
quiet

title Linux Mint 7 Gloria, kernel 2.6.28-11-generic (recovery mode)
root (hd2,0)
kernel /boot/vmlinuz-2.6.28-11-generic root=/dev/sdc1 ro single
initrd /boot/initrd.img-2.6.28-11-generic

title Linux Mint 7 Gloria, memtest86+
root (hd2,0)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sdb1
title Microsoft Windows XP Professional
rootnoverify (hd1,0)
savedefault
makeactive
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1

MY THOUGHTS:
The linux hd2 appears to be correct.
The windows portion mapping I am not sure about.

Does anyone have any ideas as to how I can fix the problem?

I really would like to keep it how it is but be able to dual boot to the different hard drives as needed. I do think that I could just load both operating systems on the SATA drive and it would probably work fine, maybe that is the easier way. Any ideas?

Thank You,
Forex Trading