Another Problem Multibooting Vista, XP and Ubuntu

#1
Hi everybody,

Just registered as a member of this forum, so I am completely new here.
I have a problem multibooting Vista, XP and Ubuntu. I cannot find a solution for on this forum or even on the web. So I started this new thread.

Dualbooting Vista and XP works perfectly allright.
After installing Ubuntu with Grub on the bootsector of the partition Ubuntu is installed to, and adding Ubuntu to the Vista bootmenu with EasyBCD 1.7.2, Ubuntu fails to boot.
It says: "Cannot load from harddisk"
Marking "Grub isn't installed to the bootsector" in EasyBCD is no solution.
I now get the Grub bootmenu, but booting hangs at: "root (hd1,9)" with a blinking cursor underneath.

Hope your expertice can help me out here.

Cheers, ben1vis.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
Hello ben1vis. Welcome to NST. I am moving this to EasyBCD Support since that is what it is. :wink:

Please check out our documentation in our Wiki in regards to Ubuntu. We give a full description on how to get it working in a multi boot enviroment.

Ubuntu - NeoSmart Technologies Wiki
 
#3
To MAKAVELI213:
To my best of knowledge I did everything the right way.
But booting from the Grubmenu fails with every item and hangs at: root (hd1,y) with a blinking cursor underneath.
I do not know where and how to proceed, so please come with suggestions, ask me questions or whatever. At the moment I am completely stuck.
 
Last edited:

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#4
Oksy did you use Ext2 file system? Did you make sure that you installed GRUB to the right place?

Here is another suggestion. Remove NeoGRUB and the Linux entry. Then add it again but this time check teh box for GRUB is not installed to the MBR. Then save your settings. Try that and see if it works.
 
#5
Thank you MAKAVELI213 for your quick reply.

- I used the Ext3 file system and not Ext2, and I am sure I installed GRUB in the right place.
- As I said before I only get into the GRUB bootmenu when I check "GRUB isn't installed to the bootsector."

Sorry, I am still stuck.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#6
Sounds liek you need to use a LiveCD and reinstall GRUB.
 
#7
Tonight I reinstalled UBUNTU and ran into the same trouble as before.
I did a reinstallation of GRUB after the first installation of UBUNTU. But to no avail.
The boot problem as mentioned remained/remains the same.

:frowning: :frowning: :frowning: :frowning: :frowning:
 

JustinW

Super Moderator
Staff member
#8
You're half way there. It is (hd1,9) that is causing the problem because you are not pointing to the right location for the Ubuntu partition. You need to change it as you boot it until you get the correct location. Once you boot, you'll need to change it in menu.lst to save it permanetly for future booting.

It appears to me that you installed Ubuntu on a second hard drive on the ninth partition, as the parameter for (hd1,9) indicates. If you meant your first hard drive (Where Vista/XP are installed), x in (hdx,y) should be 0 and not 1. The default for y in (hdx,y) is typically correct, but x is what usually causes users the most problems if they are booting Ubuntu off another hard drive. If changing x to 0 doesn't solve the problem, go ahead and try different combinations of (hd0,y) and (hd1,y) to see if you can get it to work.
 
Last edited:
#9
Hi KAIROZAMORRO,

Thank you for your reply.
Matter of fact I also got the feeling that it could have to do with this pointing to partitions.
On installing UBUNTU the installation partition was said to be: /dev/sdb10, or the other way: (hd1,9).
But I guess trying what you proposed is the only way to possible success.
As I am completely new to LINUX, would you be so kind to explain how I can tell GRUB to boot from another partition on the fly.

ben1vis

PS: All OSes are installed on the same harddisk (RAPTOR)

Addendum:

Hi KAIROZAMORRO,

:shame: Sorry about the question about editing booting GRUB. :shame: It is all in front of me on the screen. I should have started reading.
Booting UBUNTU from (hd0,9) instead of (hd1,9) works flawlessly. But editing the menu.list file looks a bit more complicated to me. Or do I only have to change the (hd1,y) values to (hd0,y)?
Now I will try the other bootitems in the GRUB bootmenu. I'll let you know about the results.
Thank you man for pointing me into the right direction.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#10
Yep, that's all you need to do. Looks like Ubuntu is mis-recognizing the correct order...

I'm guessing you have a mixed IDE/SATA setup going on? That'll throw off most bootloaders.
 
#11
You are right about a mixed IDE/SATA setup. My bootdisk is SATA and the second (data) disk is IDE.
In Windows the IDE-disk is disk 0, and the SATA-disk is disk 1.
The menu.list file is a mess: wrong about the bootdisk, unnecessary remapping of the harddisks and whatever there is more. An excellent opportunity to learn GRUB menulist editing. :smile:
 

Terry60

Knows where his towel is.
Staff member
#12
Though windows says IDE is 0 and SATA is 1 in disk management, the bootloader sees them the other way round, presumably because the BIOS points at the SATA as the 1st boot disk and the IDE as the 2nd.
(On my system at least).
That's why it's so difficult to give a definitive answer when people ask what the correct disk/partition combo is, and we end up advising trying various permutations till one works !
 
#13
Terry60 you also are completely right. The BIOS points indeed to the SATA as the first boot disk etcetera and so on.

I would like to thank all you guys for your reactions, answers and suggestions. It was very helpful. Thanks allot.
I hope others will benefit from this interesting palaver too.

:happy: Cheers, ben1vis :happy:
 

JustinW

Super Moderator
Staff member
#14
Yeah... this happens quite often actually. Install from a live CD and reboot to find you can't boot because the hard drive reference in (hdx,y) is off by a number! :rage:

Glad to hear you got it working :grinning: