Application fails to initialize

bbooker

New Member
New install. Start EasyBCD 1.7. Get "EasyBcd.exe - Application Error" box. "The application failed to initialize properly (0xc0000135). Click on OK to terminate the application."

Tried removing & reinstalling - no luck. Can't get it to run!
 

mqudsi

Mostly Harmless
Staff member
Hi bbooker, welcome to NeoSmart Technologies.

That's not a bug, as a quick search would reveal. I'm guessing you're not on Windows Vista?
If you're not on Windows Vista you need to first install .NET 2.0 then you can run EasyBCD.

Good luck.
 

VWFeature

New Member
Application fails to initialize-suggestion for enhancement

I may be hopelessly ignorant of how error messages are generated, but-you already have an error message for this-the cryptic " Application fails to initialize". Why not change it to,
" You need to install the .NET 2.0 Framework to run EasyBCD. Click on this link to install:
Download details: .NET Framework Version 2.0 Redistributable

"

?????:tongueout:

This would also reduce the number of times you have to answer this question.....
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
Hello VWFeature and Welcome to NeoSmart Technologies!

That would be fine and dandy. If it would cover all the error's that are generated. But it doesnt. This is just one of many errors that can be generated by ay application run. To jsut simply say download .NET 2.0 and install it wouldnt work for every case. It would only work on fresh install's of XP since it doesnt have .NET 2.0 isntalled already.

So as you see this isnt just a tell all error issue. :wink:
 

mqudsi

Mostly Harmless
Staff member
Actually, you're blaming the wrong party here :grinning:

While that erorr does refer to the lack of a .NET Framework installation, it's not generated by EasyBCD.

Microsoft wrote the code that displays that error message when no .NET is found and we can't change it :wink:

However, the next version of EasyBCD will check for the .NET 2.0 Framework upon installation, hopefully.
 

peacemaker

New Member
I am running Vista Ultimate SP1...Tried to run EasyBCD...got this 'Fatal error' message: "CLR error: 80004005. The program will now terminate." ...and it does. I have tried uninstalling/reinstalling to no avail...still can't get it to run.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
Sounds like a bad download. I have run EasyBCD 1.7.1 on Vista with SP1 with no problems.
 

mqudsi

Mostly Harmless
Staff member
Hi peacemaker, welcome to NeoSmart Technologies.

This error is usually caused by not having the .NET Framework 2.0 installed on Windows XP. However, Vista ships with .NET 3.0 (and Vista SP1 ships with .NET 3.5), so you shouldn't be seeing this unless your .NET installation was somehow corrupted.
 
Top