ATI 4870 CCC issue


Hey, i am fairly new to this whole graphics card driver "thing" and recently, i installed a new cooler onto my ATI 4870 (xigmatec battleaxe). Since then i have had what appears to be driver issues with my card which has just recently manifested itself in making my screen black, with the cursor visable... however i am still 99% sure that the computer and desktop are running behind it, but the graphics card or drivers for whatever reason are stopping me from seeing it.

i have tried to install new drivers (ie. CCC 9.12) but whenever i try to uninstall the old drivers or install new ones the installer tells me that it "Failed to load detection driver" and the installer/uninstaller closes.

i am really sorry if this is n00bish but i really am totaly stumped with this problem . i have tried what is sudgested here

ATI Catalyst Control Center for HD4870 - Tech Support Forum

but that doesnt seem to help, from what i can tell anyway. i have also tried to scrub my computer of the drivers using the program provided here :

any help would be REALLY appreciated with this problem

thanks guys
Hi Prose, welcome to NST.
Does the PC boot in safe mode (use F8 as you power-up to access the extended boot menu), using the default MS VGA driver.
If so, you know your card is OK and you just need to get the driver sorted.
You can also use the extended menu to try "last known good..." and to access "system restore" to take you back to a point earlier than the start of your problems.
Last edited:
thanks very much for replying

Upon closer insepction yesterday i suspect it is also partly my bios, due to the fact that there are light grey lines and errors in the text of the bios all through the menu's. The first time i tried to flash it the bios and computer worked perfectly until i ran a substantial graphic program it blanked out again with only the cursor visible like last time...

so i suspect the problem may be twofold. however this time it wont even let me through to windows... so its both the bios and the drivers... and i suspect the lack of drivers causes the computer to "forget the bios".

however ever since i flashed my bios the first time it wont do it again on command even with different memory sticks and new files... i am a bit lost at this point..

NB: my bios does not contain video drivers as it doesn't have a integrated video card. :S
We need to know if you can get into Safe Mode at all in order to be of real assistance. Try Safe Mode with Networking so you can access the internet. From there you will want to download and run Driver Sweeper to remove all signs of previous drivers.

After that try to restart in normal mode. If you can get to the desktop download and install the latest Drivers from ATi or Guru3D.|-Vista-(64-bit)-download-2448.html

Also note that there is already a hotfix out for these drivers as well:|64-bit)-download-2449.html|-Vista-(32|64-bit)-download-2450.html

If you have troubles installing the driver you can use the manual method.

1. Extract the driver install using WinRar or another archive program to a folder on your desktop. (Or other location where you know it is)
2. From there within the Driver Tab select Update Driver.
3. Choose Manual and choose the option to browse your PC for driver software. When you see the explorer window pop up, direct it to the location you just created with the driver installer extract. You will select the .inf file (As it most likely be the only file you see) and then click Okay. The Wizard will proceed to install the driver. (If the right .inf file is selected, if not select a different one)

That should install the driver for you as some people have reported that the driver install opens and closes almost instantly and they had to manually install the driver.
at this point i cannot get into windows... there are artifacts all through the bios and the words and characters are not showing up correctly on the screen.. i am beginning to suspect that this is actually a video hardware problem rather than a software one... due to the artifacts and that my computers still starting up..
If you are experiencing artifacts even at the BIOS screen it would be a hardware issue for sure. You should not see artifacts at all. It could be that the new fan install was done incorrectly as the new heatsink was mounted flat and it is causing the card to overheat or something. I would contact the place you bought the card from and see if you can get a Return Merchadise Authorization. Mount the original fan back on it and see if you can get it replaced.
yeah, ok...
strange that a change in bios software fixed it though..., i may be a n00b but that makes no sence to me....
thanks for your help though guys i really appreciate it...
got any advice on a replacement card for a 4870? i have a navidea and ATI compatible board,