ATi Driver In SuSE 10.1

#1
im trying to set up the ATi driver in SuSE 10.1 i have a Radeon X700Pro PCie card. i installed it per ATi instructions but i am missing files from "/etc/X11/xorg.conf" when i check to see if the driver is completely installed per "# aticonfig –initial –input=/etc/X11/xorg.conf" i get this error message:
"Copy configuration file template to /etc/X11/xorg.conf"
how do i do this?
 

XcOM

New Member
#2
ATI drivers are the hardst Graphics drivers to install in any Linux Distro, but from memory for suse 10 (should apply to 10.1 also)

Log into the root account,

Load a console termnal and type:
# cd /usr/src/linux
# make mrproper
# make cloneconfig
# make modules_prepare

Now to clean your kernal:

# make clean
If you have ATI drivers installed then remove them:

# rpm -e $(rpm -qa | grep fglrx)

Now download the correct drivers for you Disrto:

https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=300

Make sure you download them to your root folder,

You now need to shut down Gnome/KDE or X Server as it is refured to in Suse by:

#init 3

If asked enter your root password,

Build the installer for:

SUSE 10.1 32bit:
# sh ./ati-driver-installer-xx.xx.xx-x86.run –-buildpkg SuSE/SUSE101-IA32

SUSE 10.1 64bit
# sh ./ati-driver-installer-xx.xx.xx-x86_64.run –-buildpkg SuSE/SUSE101-AMD64

Suse 10 32bit
# sh ./ati-driver-installer-xx.xx.xx-x86.run –-buildpkg SuSE/SUSE100-IA32

SUSE 10 64bit
# sh ./ati-driver-installer-xx.xx.xx-x86_64.run –-buildpkg SuSE/SUSE100-AMD64

Where xx.xx.xx is the version of your run file.


Now to install the driver:

SUSE 10.1 32bit
# rpm -ihv fglrx64_6_9_0_SUSE101-xx.xx.xx.i386.rpm

SUSE 10.1 64bit
# rpm -ihv fglrx64_6_9_0_SUSE101-xx.xx.xx.x86_64.rpm

SUSE 10 32bit
# rpm -ihv fglrx64_6_9_0_SUSE100-xx.xx.xx.i386.rpm

SUSE 10 64bit
# rpm -ihv fglrx64_6_9_0_SUSE100-xx.xx.xx.x86_64.rpm

Now you need to configure your system (This is where ATI dosen't explain correctly)

# aticonfig –-initial -–input=/etc/X11/xorg.conf

If you get errors about a faulty command enter:
# aticonfig –-initial

Now enter:
# sax2 -r -m 0=fglrx

Last but not least:
# reboot

All done.

Info from:
http://susewiki.org/index.php?title=Installing_ATI_Video_Drivers
 
#3
thanks XcoM. same error. the instructions you posted are the same as i found at The Jem Report which are the same as the wiki set. i dont know if i just did not install something from the begining or what, but as soon as i run "sax2" i get the config screen and am prompted to keep or change settings, so since the screen looks perfect i choose keep settings. and thats the end "out of range" even blindly i reboot (through command) just in case but no go. i've reinstalled the OS and right now i'll just live w/o 3D support until i can find the reason for this error.

thanks again Neo Smart Technologies.