Attempting to dualboot Win7/Snow Leo

#1
I previously had a Vista/Leopard dual boot, and EasyBCD made that easy as could possibly be. Now I've upgraded both OS's and I can't get EasyBCD to boot the Snow Leopard HDD.

Each OS has it's own HDD.
I'm using the 2.0 beta (latest as of yesterday)
I can boot both OS's by choosing the HDD to boot in the BIOS.
When I try to boot to Snow Leo from the EasyBCD created bootloader, I get dropped to a Grub> prompt. I never get to Darwin.

I feel like, from reading the forums, that EasyBCD should be creating a file called nst_mac.efi (or something...) in the NST folder of my System Reserved (boot) drive.. but instead, when I add the bootloader entry, I get a file called AutoNeoGrub0.mbr. I'm choosing EFI and leaving the custom drive unchecked. I've never seen it make the file with the .efi extension.

Here's what my EasyBCD configuration looks like..
There are a total of 2 entries listed in the bootloader.

Default: Windows 7 Ultimate
Timeout: 5 seconds.
Boot Drive: J:\

Entry #1
Name: Windows 7 Ultimate
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: NST Mac OS X
BCD ID: {94e2a6b4-bb67-11de-8128-d0ee16e7dbf3}
Drive: J:\
Bootloader Path: \NST\AutoNeoGrub0.mbr

Drive c: is Win7
Drive j: is the System Reserved partition Win7 created during install.

I believe the whole system boots actually from drive J. I'm fairly n00b at all this, but I haven't seen forum posts with this same problem.

Any ideas?

Thanks..
-FP
 
#2
Hello funkpump, hope you find the NST forums helpful.
Have you tried using the EFI option when adding the Mac OS X entry in EasybCD?
You can select drive 1, since its the second disk that Mac has installed to.
 
#3
EFI option..

That's really my point. I am selecting the EFI option, and I've tried every drive number under the sun (I have 4 HDDs..). But instead of EasyBCD writing the .efi file, it writes the neogrub.mbr file! If I select the MBR option, it writes a different file with an .mbr extension (not neogrub but just hangs when I try to boot..). Does that make any sense?

-FP
 
#4
Weird...it definitely shouldn't be doing that.
Must be a bug.
Guess you'll have to wait for CG's input on the matter.
 
#5
One more note-
I have Macdrive installed, but since I was wondering if it was the culprit, I tried disabling it and then starting over with exactly the same end result..
 
#6
One more note-
I have Macdrive installed, but since I was wondering if it was the culprit, I tried disabling it and then starting over with exactly the same end result..
What do you mean? Is the "Macdrive" the one you have Snow Leopard installed to? If so, you obviously can't disable it, and still be able to boot it ! :brows:
 
#8
Ahh..ok. That makes more sense. :smile:
(Still waiting for CG to take over in this thread...)
 

kevwil

New Member
#9
I'm having the exact same issue, and the EFI option did the same thing for me. I can boot into either the OSX HDD (Chameleon 2.0RC3 EFI bootloader) or the Win7 HDD (drive 0) by changing the HD boot order in the bios.

I can't get EasyBCD 2.0 Beta 76 to boot into OSX, nor can I get Chameleon to boot into Windows. It seems I should be able to boot from EasyBCD into OSX by putting Chameleon's "chain0" file on the Windows drive and using that in the boot config, like "C:\chain0 = Mac OSX" or something similar. I can't figure out how to do that from EasyBCD GUI and I don't see a C:\boot.ini file that I could hand-edit.
 
#10
Hi kevwil, welcome to NST.
EasyBCD is NOT the bootloader, it is just a tool for manipulating the Vista/Win 7 BCD file for their bootloaders. And there is no boot.ini for Vista and up; it was replaced with the BCD which can only be edited with either the command-line tool "bcdedit.exe" or through the GUI of EasyBCD. The actual boot manager of W7 is the file called "bootmgr" which you will find in the root of your "system" partition (as seen from Disk Management).

Not much I can do to help you with your OS X problem though...
I'm pretty sure CG ("Computer Guru") though is working very hard on full OS X support for the next beta build, so hopefully both of you can get your problems fixed soon.

In the meantime, stick around, and help out where you can, if you'd like. :smile:
 
#12
One more thing-
I've finally found a post or two with similar (but not identical) problems. Just so you know- I do not need a CD in the drive to boot to OSX. If I select the HDD in my BIOS using F12, I can boot into Darwin and then OSX with no problems and no cd present.
-FP
 
#14
I'm sorry, funkpump. I would have thought CG would have showed up in this thread, and made a post, by now.

As it is, I myself know very little about the innerworkings of Darwin, so I can't be of much help. But it sounds like NeoGrub is failing to chainload it, for some reason, and I have no idea why that is.

(I don't think it because its of that .mbr file, though that's what I originally thought; I think that file is what the newer builds of EasyBCD's NeoGrub for OS X use now, instead of the .efi, though I don't know this for a fact)

Anyway, CG made it very clear in other posts that the OS X support is still limited with 2.0 Beta. The word is he's devoting his full attention to it with future builds, though, so I guess you'll have to stick around and wait till the next build.
 
#15
I have the same issue.

I have added the EFI Option in EasyBCD as my OSX86 install uses Pc_efi and EasyBCD reports that the bootloader path is: \NST\AutoNeoGrub0.mbr

But If i select the Option to boot into OSX on the boot menu, it loads a command-line screen which looks like grub =/

It doesn't seem to be loading the correct thing.
 
Last edited:

JustinW

Super Moderator
Staff member
#17
OS X support is a work in progress. If you stick around and post as much details you have on the problem CG might be able to correct it.
 
#19
Ok, you can start by posting the contents of the /NST/menu.lst.
 
#20
I believe this is part of the problem. My boot drive is J: System Reserved. This is the partition created by Windows 7. In that drives NST folder, there is only 2 files, AutoNeoGrub0.mbr and NST_OS_X.iso. I've watched this folder as I add/remove entries in EasyBCD, and the .mbr file gets erased/created as I would expect.

If I unassign the drive letter to J (even though I believe that to still be where I boot from, as I select that hard drive in bios), then the boot drive in EasyBCD changes to D:, which is my XP install. There is also an NST folder on that drive. It has the same two files, plus menu.lst, NeoGrub.mbr, nst_mac.efi and nst_mac.mbr. I had thought these were remnants of trying to use EasyBCD on that OS install and unimportant, but if I don't have a drive letter assigned to System Reserved (as above) then this directory is where EasyBCD will create/erase the AutoNeoGrub0.mbr file instead of the other drive.

Here's the contents of that menu.lst file even though I don't believe it to be my boot drive, but it's the only menu.lst I've got!
# NeoSmart NeoGrub Bootloader Configuration File
#
# This is the NeoGrub configuration file, and should be located at D:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
# http://neosmart.net/wiki/display/EBCD/


find --set-root --ignore-floppies /NST/nst_mac.efi
kernel /NST/nst_mac.efi
boot

# All your boot are belong to NeoSmart!


So does that shed any light on the issue?

Thanks in advance for helping!
-FP