BackTrack 5 multi-boot on portable media?

I have found a number of posts explaining why it was impossible to add BackTrack 3 and 4 ISOs as a boot entry in EastBCD for external media. I tried to see if anything changed with BackTrack 5, but connecting ISO as a boot entry in EasyBCD still results in issues.
Can anyone recommend the best practice to work around this if I need to boot BackTrack from my USB flash drive as one of the EasyBCD entries. There are 8 boot entries in total on my USB drive now. 6 of them are ISOs, one more - WinPE and BackTrack would be the last one. I would prefer some containerized version of deployment - if not ISO - then maybe VHD or some other container (if there is a recommended and proven way to do it).
I would also really appreciate if people only respond to this thread if they have done this successfully specifically with BackTrack 5. I am sure I know most of the possible options I can try (I have at least a dozen ways to approach this task in my mind already). The reason I am asking the question in the forum is to save myself all the experimenting and hopefully get a specific best practice for this particular scenario.


Super Moderator
Staff member
I think its another one of those ISOs that doesn't play nice with grub's ISO emulation. I've only got Backtrack working in an extracted form with boot via grub.
I found this website (This Is Thought Crime) a few days ago and respun my initrd. I couldn't get the script to work so I just followed the commands, worked out what was going on and did it all manually.
#!/bin/sh -eif [ "$1" == "" ]thenecho "specify path to initrd please"exitfimkdir -p tmp/initrdcd tmp/initrdgzcat $1 | cpio -iecho "downloading lupin"cd ..wget --no-check-certificate -zxvf lupin_0.32.tar.gzecho "updating initrd"cp -r lupin/casper/scripts/* initrd/scripts# update scripts foldercd initrd/scriptsfor i in casper-premount casper-bottomdoecho $itouch $i/ORDER.newls -1 $i |grep -v ORDER |while read line; do echo /scripts/$i/$line >> $i/; echo '[ -e /conf/param.conf ] && . /conf/param.conf' >> $i/;donemv $i/ $i/ORDERdonecd ..find . | gnucpio -H newc -o | gzip > ../initrd.gzcd ../ tmp/initrd.gz .#rm -rf tmpecho "done, new initrd is ./initrd.gz"
Once done you place the respun initrd onto you thumbdrive and point to it instead of the one in the isoMy menu entry looks like this in Grub2menuentry 'Backtrack 5'{ set root='(hd0,gpt13)' loopback loop (hd0,gpt13)/BT5-GNOME-32.iso linux (loop)/casper/vmlinuz file=/cdrom/preseed/custom.seed boot=casper initrd=(hd0,gpt13)/boot/initrdBT.gz iso-scan/filename=/BT5-GNOME-32.iso noeject noprompt splash -- initrd (hd0,gpt13)/boot/initrdBT.gz}
its not working in windows 7 if u have dual operating system example if u use linux or ubunto or some other u can use this software.....
i have a prb could u any one suggest me that haw can i run back tack 5 in windows using vmware player. when i open the player there says to me that the operating system was not found ...... wait for instruction .. Thank you