Base Filteringe Engine: service cannot find the file?

#1
Hi neosmart members! I searched for a community with a higher level of expertice than can be found on any other windows-related forums and finally decided to post here. :smile:

I'm a x64-user and I do not have any other firewall software installed except for the one that is included with windows.

I first noticed my problem when windows firewall wasn't activated and was unable to activate it.
I found that the problem was that the Base Filtering Engine service wasn't able to start and the error message said that "the system cannot find the file specified". I suppose it means that it can't find the BFE.DLL-file. The problem is that the file already is in the %systemroot%\system32\ folder.

I suspect that the svchost command to activate the base filtering engine service (%systemroot%\system32\svchost.exe -k LocalServiceNoNetwork) isn't working but I don't know how to see any evidence of that... Or am I on the wrong track?

Any help is appreciated! :smile:
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Musenkishi, welcome to NST.

Please check the the Event Viewer for any related errors, and post them here:
Control Panel | Administrative Tools | Event Viewer

BTW, this is Windows Vista, right?
 
#3
Please check the the Event Viewer for any related errors, and post them here:
Control Panel | Administrative Tools | Event Viewer

BTW, this is Windows Vista, right?
Yes, this is Windows Vista Ultimate x64 edition. I believe Vista (and above) is the only OS from microsoft that has the base filtering engine service.

I can't seem to find any related material except for this event:
Code:
[URL="http://neosmart.net/forums/#"]The Base Filtering Engine service terminated with the following error: 
The system cannot find the file specified.[/URL]
[code][URL="http://neosmart.net/forums/#"]-[/URL] <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
   [URL="http://neosmart.net/forums/#"]-[/URL] <System>
     <Provider Name="Service Control Manager" Guid="{555908D1-A6D7-4695-8E1E-26931D2012F4}"-
EventSourceName="Service Control Manager" /> 
    <EventID  Qualifiers="49152">7023</EventID> 
    <Version>0</Version> 
    <Level>2</Level> 
    <Task>0</Task> 
    <Opcode>0</Opcode> 
    <Keywords>0x80000000000000</Keywords> 
    <TimeCreated SystemTime="2008-07-16T12:48:10.000Z" /> 
    <EventRecordID>3</EventRecordID> 
    <Correlation />  
    <Execution ProcessID="0" ThreadID="0" />  
    <Channel>System</Channel> 
    <Computer>Fredy</Computer> 
    <Security />  
   </System>
  [URL="http://neosmart.net/forums/#"]-[/URL] <EventData>
     <Data Name="param1">Base Filtering Engine</Data>  
    <Data Name="param2">%%2</Data> 
   </EventData>
   </Event>
[/code]It's the same error code (2) that i get when i try to start the base filtering engine service through services.msc.
 

mqudsi

Mostly Harmless
Staff member
#4
Run
Code:
sfc.exe /scannow
to check for modifications to system files.
 
#6
Solved the problem with a complete-pc backup from last month. If anyone has any solution then you are more than welcome to reply to this thread. :smile:
 
#8
Hi there. I seem to have the same problem as musenkishi, with firewall not turning on, base filtering engine not turning on and so on. My whole reason for this is I am trying to install Zune software. It wouldn't work, so i called tech guys at zune and he basically said i need windows firewall turned on to install it, and it won't. I have taken the suggestions and ran the scan for system file modifications. This is what came up :

details are included in the CBS.Log windir\logs\cbs\cbs.log. . . . .

I'm not sure if this is related or not. Honestly, I'm not super at computer problems, but I'm trying to solve this myself so i don't have to pay 50 ridiculous dollars for geeksquad. Any help would be appreciated.
 

Terry60

Knows where his towel is.
Staff member
#9
Hi chaos, welcome to NST.
Have you tried control panel/admin tools/services
right click on base filtering engine, restart it and set it automatic in the properties dialogue.
 
Last edited:
#10
yeah i've done all that, it won't turn on at all. i was looking at some other forums and found a guy that had the same problem as me, so i followed the steps he took as far as i could. apparently he used the command prompt and scanned for missing or corrupt files, which led to him finding the broken file, replacing it and fixing the problem.. my problem is that nothing came up for files that have to do with the BFE. the only thing that came up said something about windows sidebar. At the end it says all files have been repaird though, so obviously there is no problem whatsoever . . . i am lost.

a lot of this is technological mumbo jumbo to me, but i'm starting to understand it. :smile:

Addendum:

i also understand that the BFE depends on the RPC to start, but the RPC is started
 
Last edited:

JustinW

Super Moderator
Staff member
#11
If possible, restart all services BFE relies on as well as BFE. If the problem persists there may be a hotfix.. You'll need to search MS help for it.
 
#12
I've done all that too, and I've already searched the web for a week looking for an answer. Nothing is helping. I'm pretty sure I'm just going to have to breakdown and call GeekSquad. :frowning:
 

JustinW

Super Moderator
Staff member
#13
Geek Squad well just re-format and re-install the OS completely. If thats the route you want to take save yourself the money by doing it yourself or having a friend do it for you.
 
#15
and how would i go about doing that?
Do you have a Vista reinstallation DVD? If so, then you can use the installer to reformat the Vista partition, and then just simply reinstall Vista.
You will need to boot from the DVD, which can be accomplished by rebooting, and entering your BIOS (by pressing whatever key it tells you to press at the first splash screen you get to at startup). Once in the BIOS, you need to put the CD/DVD drive (or whatever the name is in your BIOS) first in the boot sequence, or boot order. Once you have the CD drive at the top, above the rest of the devices shown there, simply save the changes you made, and exit the BIOS. You should now see a message saying "Press any key to boot from CD". So press a key to begin the installation program for Vista. Once you get into there, just format your Vista partition, and reinstall Vista.
 

Terry60

Knows where his towel is.
Staff member
#16