BCD config inaccessible


New Member
Hello NeoSmart community,
I have a very weird problem with BCD that I'm unable to fix so I'm hoping for support here.

First of all. I run Windows 7 and my system runs and boots perfectly fine, I just can't alter the system BCD anymore in any way.

The problem was caused by my own stupidity: I don't shut down my PC but hibernate at the end of the day because that makes my system much faster in booting. So I few days ago I pressed hibernate, left the room, came back and thought the PC already finished hibernating so I cut the power. Turned out the PC was still in process of hibernating when I did that.

Next morning Windows said it wasn't shutdown properly but booted fine, just ever since that day I'm unable to hibernate because Windows can't access it own BCD settings anymore.

If I open msconfig.exe the Start tab is empty, if enter "bcdedit /enum" in a CMD I get the following error (freely translated from german): "The memory for the start configuration files could not be opened. The requested system device could not be found"

If I open EasyBCD 2.02 I get:

"Error opening BCD Registry

The boot configuration data store could not be opened.
The requested system device could not be found

Would you like to manually load a BCD registry for EasyBCD to manage?"

I tried every available repair option in BCD, including MBR Rewrite, BCD Rewrite and I even tried EasyBCDs option to set another boot drive for Windows, no avail.

Note, I have 4 internal HDDs and each is fully working, the HDD and partition where my BCD is/was was checked by Chkdsk and set as active.

I'm at a loss here, I just want to be able to configure BCD again,
thanks for any reply in advance!


New Member
Thanks for the reply, I tried what you said.
Startup Repair detected a problem and fixed the first time obviously because I renamed the BCD file. Afterwards I could still boot fine but neither Windows nor EasyBCD still wouldn't see the system BCD.

Further Startup Repairs detected no problems. It seems to me that the BCD system itself is perfectly fine, just Windows doesn't know where to look for it anymore.

Is there any Registry Entry that tells Windows where to look for the system BCD that I could perhaps manually edit?

Thanks again in advance!
Last edited:


Super Moderator
Staff member
Do the other actions before startup repair. Though startup repair automatically detected a problem, it ovbiously wasn't able to fix it.


New Member
I did the others action and Startup Repair found a problem and fixed it the first time.
Now 7 still boots fine, however BCD is still inaccessible inside 7.

I tried 3 Startup Repairs afterwards now, each of the 3 times it said: "No problems could be detected"

It's not really a BCD problem, more like a Windows 7 problem. BCD is there and functional just Windows can't see it.


Case closed it was a sudden incompatibility with my Chameleon USB boot stick, after removing it everything works. Strange after 2 weeks of working fine but oh well...
Last edited: