BCD is Wrong

#1
Using EasyBCD 2.3 I have edited the BCD menu (I'm using Windows 7 x64), but although the changes display in EasyBCD, they do not display in the actual boot menu.


I am trying to create a full-utility USB boot drive I can carry in my travels. I have a Dell OEM Windows 7 installation on the disk so that I don't need the CD (I'm always installing on Dells, that's why it's OEM).

Now, here is what EasyBCD says:

There are a total of 10 entries listed in the bootloader.
Path: N:\Boot\BCD

Default: WonderShare LiveBoot
Timeout: None
Boot Drive: N:\

Entry #1
Name: WonderShare LiveBoot
BCD ID: {default}
Device: boot
Bootloader Path: \NST\AutoNeoGrub16.mbr

Entry #2
Name: Saint Virtulus
BCD ID: {bbd6e056-ce9b-11e5-b789-005056c00008}
Device: [locate]\bootiso\SainVirtulus.vhd
Bootloader Path: \Windows\system32\winload.exe

Entry #3
Name: gParted
BCD ID: {cd3a5bfa-8812-11e5-917d-10bf4885a645}
Device: boot
Bootloader Path: \NST\AutoNeoGrub15.mbr

Entry #4
Name: Ultimate Boot Disk
BCD ID: {f3e5f4da-8812-11e5-917d-10bf4885a645}
Device: boot
Bootloader Path: \NST\AutoNeoGrub17.mbr

Entry #5
Name: Hiren's Boot Disk
BCD ID: {00760d2a-8813-11e5-917d-10bf4885a645}
Device: boot
Bootloader Path: \NST\AutoNeoGrub18.mbr

Entry #6
Name: oph crack
BCD ID: {1e456dfa-8813-11e5-917d-10bf4885a645}
Device: boot
Bootloader Path: \NST\AutoNeoGrub19.mbr

Entry #7
Name: PassHack
BCD ID: {2a588e1a-8813-11e5-917d-10bf4885a645}
Device: boot
Bootloader Path: \NST\AutoNeoGrub20.mbr

Entry #8
Name: FreeDOS
BCD ID: {3dcdf07a-8813-11e5-917d-10bf4885a645}
Device: boot
Bootloader Path: \NST\AutoNeoGrub21.mbr

Entry #9
Name: Windows10
BCD ID: {f16d85b0-8ef6-11e5-917d-005056c00008}
Device: boot
Bootloader Path: \NST\AutoNeoGrub22.mbr

Entry #10
Name: Win7 Install
BCD ID: {10f1c8ec-ce78-11e5-b536-d067e53b27f5}
Device: [boot]\bootiso\Dell_OEM_Windows7_with_updates\sources\boot.wim
Bootloader Path: \Windows\System32\Boot\winload.exe

But look at what Visual BCD Editor says:
screenshot_VisualBcd_001.png


But you can see that Visual BCD reports a loader for "Windows 7" AND "Win7 Install". Easy BCD reports "Win7 Install", but the actual boot menu only says "Win7". It got this way after my editing the BCD store using Easy BCD. Something is wrong with the way it reads or writes.

How can I provide more info here?